Issue of question order on side menu

More
2 weeks 6 days ago #171900 by yahasun
yahasun created the topic: Issue of question order on side menu
I have limesurvey 3.7.3 setup with postgresql 9.5
One survey with 2 question groups and several questions. The question group order is different on postgresql and mysql. See the screenshots, on postgresql, the later added group ( here is "General Questions") shows on the top, but on mysql, the latest added group shows at the bottom, which is correct I guess.

Can anyone instruct me where to check and make the question/group order the same as mysql?
Attachments:

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #171903 by DenisChenu
DenisChenu replied the topic: Issue of question order on side menu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #171909 by yahasun
yahasun replied the topic: Issue of question order on side menu
Thank you Denis.
I follow the proposal in bugs.limesurvey.org/view.php?id=13677 to strip "|| 999999" part, and then delete tmp/assets/*, but still see incorrect order. :(
Is there a plan which release will have this fix?
Will fix solution be stated in the bug report?

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #171910 by ollehar
ollehar replied the topic: Issue of question order on side menu
Please update to the latest version. A lot of bugs has been fixed.

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #171911 by ollehar
ollehar replied the topic: Issue of question order on side menu
In case of problems, go to the question organizer and save the group order. Then clear the browser cache and reload the page.
The following user(s) said Thank You: LouisGac

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #171912 by yahasun
yahasun replied the topic: Issue of question order on side menu
Sure, I'll try. Thank you!

Please Log in or Create an account to join the conversation.

More
2 weeks 6 days ago #171930 by yahasun
yahasun replied the topic: Issue of question order on side menu
I've tried latest 3.14.0 , with no luck :(, bug #13677 is not fixed at this release.

Please Log in or Create an account to join the conversation.

More
6 days 12 hours ago #172353 by etutora
etutora replied the topic: Issue of question order on side menu
Hi all,
I'm also having the problem with the order of the questions. I can see the correct order in "Reorder questions/questions groups" but the LS changes the order of 2 questions within one group.
I just update the LS to the version 3.14, but had no luck.
Thanks in advance for your help.
Maria

Please Log in or Create an account to join the conversation.

More
6 days 12 hours ago #172357 by etutora
etutora replied the topic: Issue of question order on side menu
Hi,
I tried to activate the survey and got the error message ("Bad duplicate fieldname") about the 2 questions that were in the incorrect position. Tried to go back to the survey.
Now, panic, the survey has no questions anymore. Gone?
I do not know what to do.
Greetings,
Maria

Please Log in or Create an account to join the conversation.

More
6 days 12 hours ago #172358 by etutora
etutora replied the topic: Issue of question order on side menu
Hi, again.
Sorry for the many posts.
I was able to import a backup. The questions are in the right position. I just lost an hour or so of work. But I'll move on from that backup.
Disregard my posts.
Have a nice day,
Maria

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!