Map Search Box not showing

More
5 months 1 week ago - 5 months 1 week ago #171045 by lalato
lalato created the topic: Map Search Box not showing
I'm trying to use Short Free Text with a Map to capture location data. When I first created the question, there was a search box above the map followed by Latitude and Longitude fields. Now, suddenly, the search box has mysteriously vanished. The map and lat/long boxes are still there.

Any idea how I get it back?

Thanks!
LS 3.13.2+180709
Last Edit: 5 months 1 week ago by lalato.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #171050 by DenisChenu
DenisChenu replied the topic: Map Search Box not showing
What map typ you use ? Can you look at your javascript console log (can be shown with F12 with firefox)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #171129 by lalato
lalato replied the topic: Map Search Box not showing
Map: OpenStreetMap.
OS: MacOS 10.13.5

One thing I noticed this morning... It appears to be working in Safari, but not in Firefox or Chrome.

In the Firefox Console, I see several CSS warnings, but nothing else.

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago #171138 by DenisChenu
DenisChenu replied the topic: Map Search Box not showing
Can you give us a link to a simple survey with just the map ?
To see if we have issue too or not.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago #171146 by lalato
lalato replied the topic: Map Search Box not showing
Here's a link to a single question survey with just one short text question and map.

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago #171148 by Joffm
Joffm replied the topic: Map Search Box not showing
Hi, lalato,

there is no link.

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago #171193 by lalato
lalato replied the topic: Map Search Box not showing

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago #171215 by DenisChenu
DenisChenu replied the topic: Map Search Box not showing
Oh … sh… something only on Mac …

Sorry … no solution for me … (it work or firefox and chromium).

Maybe report the issue to the bug tracker

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
5 months 6 days ago #171225 by lalato
lalato replied the topic: Map Search Box not showing
I have submitted a bug report.

This is such a strange issue. It was working before in Safari, but now it doesn't work for me in any browser.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171560 by lalato
lalato replied the topic: Map Search Box not showing
This appears to be an encryption issue.

When LS is setup with https OpenStreetMap doesn't display the search box. When it is set up without encryption the search box displays without issue.

There could also be some MacOS related component here, but the workaround for me (at least for OpenStreetMaps search box) is to run the survey without https.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171571 by DenisChenu
DenisChenu replied the topic: Map Search Box not showing
Hi,

Sorry : it's for search box, right, currently we disable it for https, we need to update to another API .

github.com/LimeSurvey/LimeSurvey/blob/30.../scripts/map.js#L226

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171629 by lalato
lalato replied the topic: Map Search Box not showing
What is strange to me is that there are times when it appears to work fine with https, but other times it doesn't.

Please Log in or Create an account to join the conversation.

More
4 days 2 hours ago #178382 by lalato
lalato replied the topic: Map Search Box not showing
Sorry to resurrect an old thread, but wondering if any changes have been made or if there are any new map APIs available for use?

Please Log in or Create an account to join the conversation.

More
3 days 18 hours ago #178391 by DenisChenu
DenisChenu replied the topic: Map Search Box not showing
4 montsh : not so old, else : no update on this issue

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!