New record added each time survey page is visited

More
2 years 11 months ago #107673 by byan
Dear all,

I have a one-group survey running on 2.05+ (140414). Each time a user visited the survey page, a new record was added even though the user just browsed the survey and didn't do anything. I tested the same survey on the 1.9 LS version and found no new record was added unless at least one question was answered.

Is there a way to ask LS (2.05+) not to add a record unless the respondent has answered at least one question? Thanks!

Please Log in to join the conversation.

More
2 years 11 months ago #107705 by DenisChenu
what is the survey format ? All in one, Question by questio ?
Do you set 'show welcome' to no ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
2 years 11 months ago #107727 by byan
All in one
No "show welcome'
Yes 'date stamp'
Yes 'save ip address'
Yes 'save referrer url'
Yes 'save timing'
token enabled

Please Log in to join the conversation.

More
2 years 11 months ago #107728 by DenisChenu
Can you try with:

All in one
"show welcome' to YES

(you leave welcomtext empty)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
2 years 11 months ago #107729 by byan
Thanks! Just tried. The problem persisted. A test survey is attached.
Attachments:

Please Log in to join the conversation.