Issues with visibility of answers

More
5 months 1 week ago #180180 by Consultor
Good afternoon, we have problems to visualize recommendations that we are incorporating based on the answers given to certain questions in a questionnaire. In the attached screenshot you can see that the question has a visibility criterion based on the answers given above (questions A3, A7, A8, A10, A11, B1, C2, C3, C4 and C5) and a variable that contains the score obtained in the questionnaire (X22).

When making a test of the questionnaire, the recommendations are not shown even though they meet the conditions required by the "if". However, if you show us the score obtained that also contains your corresponding "if".

Is there any limitation on the number of "if" or visibility conditions for the questions?

Thank you.
Attachments:

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
5 months 1 week ago #180190 by elissa
Hi,
maybe the problem results from the using of the single "=" in the equation "X22=round..." (marked in red in your screenshot).
Regards

Elzbieta Lesinska
LS voluntary Polish translator and supervisor

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #180192 by jelo
Right, this calculation should be placed in a equation question. Perhaps you create a small survey with just 2 questions and a recommendation IF page and attach the LSS export here.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #180193 by Consultor
Hi,

In that question the value is assigned to variable X22.
The problem is in the other screenshot, maybe it's because we have many IF conditions.

Regards

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #180195 by Consultor
The calculation is in an equation question and we have created a small survey and it works.

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #180202 by holch
Jelo is asking to post the test survey here, with only the questions that are the problem.

Post it as an LSS file here, that can help to check your approach.

Otherwise it is quite difficult to do this from 2 screenshots.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #180205 by jelo

Consultor wrote: In that question the value is assigned to variable X22.
The problem is in the other screenshot, maybe it's because we have many IF conditions.

elissa already pointed out the red "=" sign. X22 is not changed via that equation.
But as holch pointed out, a screenshot is not the best way to debug.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
5 months 1 week ago #180231 by DenisChenu
I update manual just now : manual.limesurvey.org/index.php?title=Ex...=135018&oldid=135017

Maybe it's this ?

Assignment is done only in PHP. This don't update any value on same page, but only when user move next, previous save ….


Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!