Check out the LimeSurvey source code on GitHub!

Installed the XAMPP package but cant Log in as an admin to the local host

More
3 years 3 weeks ago #104236 by hk280
Attempted installation of the package, all went well and I followed the instructions to the letter (except I ultimately set Chrome as the browser because I dont have firefox), but when it directed me to the local host I was unable to log in as username: admin, password: password, as it says I should be able to here: manual.limesurvey.org/Installation_of_th...Survey_XAMPP_package . Can anyone help me, I don't know if its just so obvious that I cant see it or if I need to try to install it again (which I probably will do in a couple hours). Also I have a windows 8.. not sure if that precludes the program from functioning.

Please Log in to join the conversation.

More
3 years 3 weeks ago #104239 by holch
I have seen quite a few people struggling with the XAMPP installer. Seems that there is something broke. I am not sure if anyone of those who noticed the problem wrote a bug report. If not, it will probably not get fixed anytime soon.

Install Limesurvey on your own in another folder in the htdocs (or www) folder. It is quite easy. There you can set the password yourself.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

More
3 years 1 week ago #104832 by Vivi01
Me too, had similar problem. I followed the installation steps ( manual.limesurvey.org/Installation_of_th...Survey_XAMPP_package ) correctly and installed XAMPP package on my Window 7 machine, but could not get my browser (IExplore) to open http://localhost/admin (step3 of the installation) and login. Instead, I received following error:

Internal Server Error
CDbconnection failed to open the DBconnection

You mentioned try install Limesurvey in another folder in the htdocs folder. Could you be more specific how to do so (instruction procedures?). FYI. I can locate c:\xampp\htdocs folder but not sure how and what to install..


Please help

Please Log in to join the conversation.

More
3 years 1 week ago #104836 by c_schmitz
If you had problems please uninstall the old LimeSurvey on XAMPP package using the windows installer, wipe the xampp dir completely and install the latest build (xampp package) released a couple days ago. That one will properly install.

Best regards

Carsten Schmitz
LimeSurvey project leader
The following user(s) said Thank You: LoKa

Please Log in to join the conversation.

More
2 years 9 months ago #107837 by Jonty_66
I tried to install the xampp package yesterday then the new version today. In both cases I get the same error message in the browser "Internal Server Error

CDbConnection failed to open the DB connection." as reported by others.

And yes I completely wiped the xammpp directory between the 2 installs!

Any advice what to do next?

Please Log in to join the conversation.

More
2 years 9 months ago #107893 by steve_81
Hey,

I have the same problem with this release (2.05plus 20140422) and in the live chat at least one more user claims it.
So I made a bug report: bugs.limesurvey.org/view.php?id=8997

Hope the developers solve this prob. I really want to test limesurvey.

Stefan

Please Log in to join the conversation.

More
2 years 9 months ago #107930 by Jonty_66
I installed WAMP on my Pc then installed the "full" version of Lime survey into the www folder of WAMP. That works fine and I have begun testing it. I tried to do the same with XAMPP, installing limesurvey into htdocs but I couldn't make that work.

WAMP rules????

Please Log in to join the conversation.

More
2 years 9 months ago #107931 by holch
I am using WAMP as well and things work fine. But before I had always used XAMPP as well, but not the Limesurvey package, but the normal XAMPP, installing Limesurvey into a subfolder of htdocs. Should be no problem.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 9 months ago #107937 by c_schmitz
The LimeSurvey XAMPP package is currently broken. We are working on a fix.
If you already installed it just delete /application/config/config.php
Then visit http://localhost/admin with your browser and walk the installation procedure.

The database access data would be

db name: limesurvey
db user: root
db password: (empty)

Best regards

Carsten Schmitz
LimeSurvey project leader
The following user(s) said Thank You: holch, OgreAbroad

Please Log in to join the conversation.

More
2 years 9 months ago #107940 by steve_81
@ c-schmitz: You are a genius. With this little workaround everything works fine.
Thank you.
Stefan

Please Log in to join the conversation.

More
2 years 9 months ago #107944 by holch
Hi Carsten,

Thank you for clarifying this! The XAMPP package comes up in the forums now and then. Would be great if we could take this package from the download section until the issues are resolved.

I think the way it is now, it only creates frustration for the users and usually it is the users with the least experience who download this. They might not even come to the forum, think they are stupid and just give up.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: banboo

Please Log in to join the conversation.

More
2 years 9 months ago - 2 years 9 months ago #108015 by banboo
Hi,I'm a chinese. I install limesurvey base on wamp too,and installation was done.
But the bugs came out.the page warning an exception like
"fatal error:allowed memeory size of 8388608 bytes exhausted(tried to allocate 393216 bytes) in C:\wamp\www\limesurvey\application\helpers\expressions\em_manager_helper.php on line 8395"
but the version bag was download from " www.limesurvey.org/en/stable-release ", and the version bag is limesurvey205plus-build140422.zip

by the way,i installed limesurvey on xampp,but can log in,"the username or password is worng".what's the defult username & passowrd?
Last Edit: 2 years 9 months ago by banboo. Reason: add details

Please Log in to join the conversation.

More
2 years 9 months ago #108017 by banboo
never mind of my questions everybody,it's my fault.i forget change the php.ini file.thank you guys all the same.

Please Log in to join the conversation.

More
2 years 9 months ago #108297 by LoKa
The application works! Many thanks for your hints!
LoKa

Please Log in to join the conversation.

More
2 years 6 months ago #111264 by OgreAbroad
@c_schmitz... much appreciated!

I am ignorant, new to both Apache and mySQL... not a webadmin. Was looking for something that I can use in a classroom to collect feedback simply. Was struggling with XAMPP until I found this thread, and after 3 days of fighting, I now have it working!!!

Next order of business, build out a survey then figure out how to make it reachable on a LAN. Wish me luck!

BTW... hosting this on a WIN 7 instructor laptop. I know that it wasnt designed to be used on the LAN, just locally... but I have an APACHE savvy individual that I intend upon tapping to assist with that.

Thanks again!

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form