Check out the LimeSurvey source code on GitHub!

White screen during Comfort Update

More
3 years 1 month ago #103887 by mvdct
Hi mlarcelet,

That is interesting. Suggests it might not just be my issue alone.

Tell me about: "Had to restore my install from my backup"

I'm guessing if I don't already have a backup, and I guess I'd know this, then this option isn't open to me.

Please Log in to join the conversation.

More
3 years 1 month ago #103888 by mlarcelet
I confirm this (tried the update twice)
- The changelog was blank ;
- a warning said that the version.php had been modified manually (i didn't)
- The pb appears after proceeding to step 3 --> result in a blank screen
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
3 years 1 month ago #103890 by mlarcelet
@mvdct:
I perform a daily backup of the limesurvey database and the limesurvey web app folder.
I restored my database from the auto backup that LS performs just before upgrading.
I restored the app from my yesterday's backup.
The following user(s) said Thank You: holch, mvdct

Please Log in to join the conversation.

More
3 years 1 month ago #103892 by holch
Hi mlarcelet, thanks for skipping in. So we have 3 cases with problems already and you could even confirm the version (which I assume will be the same for mvdct). I am running v131206 right now and after reading this I will NOT update of course. ;-)

Would you be able to make a bug report, because with 3 cases showing up here, confirming that Limesurvey was running fine before, there is a good chance that this is a bug.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
3 years 1 month ago #103898 by iscar
all problem caused by php version.2.05 need 5.3, it will cause lots of problem.5.2 is much much better, stable.

Please Log in to join the conversation.

More
3 years 1 month ago - 3 years 1 month ago #103907 by mvdct
@holch - Totally agree. It looks like there is a bug.

@mlarcelet - That sounds exactly the same as I experienced. Useful to know. Are you OK submitting the bug report, or shall I? I'm happy to do so, but haven't submitted one before. Just let me know.


...on a slightly more personal level. Does any one have any idea how I can get my own install of limesurvey back up and running ASAP!?
Last Edit: 3 years 1 month ago by mvdct.

Please Log in to join the conversation.

More
3 years 1 month ago #103911 by holch
Did you check if your server has PHP 5.3? As Iscar says, this might be the problem?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
3 years 1 month ago #103913 by mvdct
Thanks holch.
Is iscar saying "5.2 good, 5.3 bad", or "5.2 bad, 5.3 good"?
My server is currently running PHP 5.2.
I can update if necessary, but I think iscar is saying: 5.2 good, 5.3 bad.

Please Log in to join the conversation.

More
3 years 4 weeks ago #103914 by holch
I think what he is saying is: LS 2.05 needs 5.3, but it would have been better to stick with 5.2 as it is a more stable version of PHP.

I had a quick look and Limesurvey 2.0 and later requires PHP 5.3, according to the manual:
manual.limesurvey.org/Installation#Make_...rvey_on_your_website

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
3 years 4 weeks ago #103915 by holch
So here is my "translation" of iscar's post:

all problem caused by php version.2.05 need 5.3, it will cause lots of problem.5.2 is much much better, stable.

All these problems are caused by the php version. LS 2.05 requires 5.3, but this will cause a lot of problems. PHP 5.2 is much better as it is more stable.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: mvdct

Please Log in to join the conversation.

More
3 years 4 weeks ago - 3 years 4 weeks ago #103916 by mvdct
@holch. Thank you.
So potentially upgrading to 5.3 could resolve this issue.
But might cause others in the future.
Last Edit: 3 years 4 weeks ago by mvdct.

Please Log in to join the conversation.

More
3 years 4 weeks ago - 3 years 4 weeks ago #103921 by mvdct
Upgrading my server from PHP 5.2 to 5.3 solved this issue.
Thanks to all those who gave their advice.
Last Edit: 3 years 4 weeks ago by mvdct.

Please Log in to join the conversation.

More
3 years 4 weeks ago #103927 by holch
Great to hear that it worked out for you.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 4 weeks ago #104056 by mdoherr
Dear all,
I had the same problem when using the comfort update to move from version 2.0x to the most recently available stable update. The update went all the way to step 3 (including the automatic backups) but then stopped with a white screen at step 4.
Now I can not access the installation (emmpty screen where the login window should be).
Downloaded and manually installed the latest stable version (205plus-build140116) from the Limesurvey Website following the instructions (including copying the Update folder and the Config file), however, when trying to log into the admin backend I get the same blank screen :-(
Database corrupted during update process???
Where do I find the structure and SQL database backups that are created during the comfort update process?
Any other suggestions?
THX Marcus

Please Log in to join the conversation.

More
3 years 4 weeks ago #104057 by DenisChenu

mvdct wrote: Upgrading my server from PHP 5.2 to 5.3 solved this issue.
Thanks to all those who gave their advice.


Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form