Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:

TOPIC: Souci d'installation ?

Souci d'installation ? 5 years 2 months ago #60684

  • mblanc
  • mblanc's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Bonjour,

Je viens d'installer la 1.91 Build 10060. Tout c'est bien passé.
Je peux entrer dans l'admin et créer un questionnaire.

MAIS pour visionner/tester le questionnaire il y a un pb, j'obtiens un message d'erreur :
Parse error: syntax error, unexpected T_STRING in /(monserveur)/sondage/index.php at line 2915

Je pense à un défaut de config, mais après de multiples essais sans succès, je préfère m'adresser à vous pour avoir des conseils ou des pistes !...

Merci d'avance
The administrator has disabled public write access.

Souci d'installation ? 5 years 2 months ago #60698

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2784
  • Thank you received: 365
  • Karma: 78
Je n'ai jamais eu ce type d'erreur. Mois si j'étais de toi je retransfèrerais les fichiers. Ça me fait penser à une erreur dans un fichier.

Généralement c'est qu'il manque un ; à la fin d'une ligne ou un truc du genre. Mais ça se serait vu si c'était le cas ds LS.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Souci d'installation ? 5 years 2 months ago #60716

  • mblanc
  • mblanc's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Merci.

J'ai réinstallé l'ensemble des fichiers (au lieu de l'archive zip, j'ai utilisé 7z) mais j'ai le même problème.
Sans doute une configuration particulière de htaccess ou php.ini chez 1&1 ? je suis pourtant bien en PHP 5.

Si il y a d'autres idées à creuser je suis preneur...
The administrator has disabled public write access.

Souci d'installation ? 5 years 2 months ago #60719

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2784
  • Thank you received: 365
  • Karma: 78
Sans doute une configuration particulière de htaccess ou php.ini chez 1&1 ?

Non, je suis chez 1&1 et je n'ai rieu du faire de spécial.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Souci d'installation ? 5 years 2 months ago #60838

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 9254
  • Thank you received: 1319
  • Karma: 382
Salut,

C'est un gros bug sur la version releasé de LS 1.91, corrigé depuis
bugs.limesurvey.org/view.php?id=5158

Reprend la version téléchargeable sur la page d'accueil.
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Souci d'installation ? 5 years 2 months ago #60862

  • mblanc
  • mblanc's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Merci beaucoup Shnoulle.
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61596

  • nanal
  • nanal's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
Bonjour tous le monde :)

J'ai le même soucis. J'ai uploader LS sur mon ftp (ovh mmutualisé pro, limesurvey191plus-build10120-20110525.tar.bz2 2011-05-25 22.6 MB) et j'ai ce pb :

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /homez.194/objectifg/www/limesurvey/classes/dTexts/dTexts.php on line 13

Cependant, j'ai installé la même version en local et pas de soucis. J'ai pourtant un site (drupal) qui tourne sans encombre. J'ai l'impression que c'est un pb d'écriture dans le fichier dTexts.php, mais je ne trouve pas.

Vous me direz que si ça fonctionne en local, il ne devrait pas y avoir de soucis, ou bien c'est un problème de droit... En local je suis sur ubuntu. J'ai mis les droit en 705, puis en 777 histoire de, mais pas de changements notables.

Je vais uploader une autre version et je vous fait part des résultats.
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61614

  • nanal
  • nanal's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
Le changement de l'archive n'y change rien.

J'ai testé en local, lorsque je le met dans mon /www : Can't connect to LimeSurvey database. Reason: Access denied for user 'root'@'localhost' (using password: NO)

Normal, étant donné que je n'ai pas renseigné le login et mdp de la base. Une fois renseigné, c'est tout bon...

C'est bien un soucis sur mon hébergement, mais lequel...
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61616

  • mblanc
  • mblanc's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Peut-être est-ce dû au choix PHP4 / PHP5 ?
Par défaut, OVH est en PHP4 je crois...Il faut paramétrer un htaccess pour forcer le PHP5.
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61621

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2784
  • Thank you received: 365
  • Karma: 78
Effectivement il est préférable d'utiliser PHP 5 pour LS.
Généralement une petite ligne en plus ds le .htaccess : guide.ovh.com/Php5ChezOvh
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61630

  • nanal
  • nanal's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
Il est déjà en php5 "SetEnv PHP_VER 5" :pinch:

Je vais uploader l'archive sur un autre serveur, dont je suis sur que le php5 est actif...
Last Edit: 5 years 1 month ago by nanal.
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61638

  • nanal
  • nanal's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
Cela fonctionne correctement sur mon autre serveur (php5 valide).

Cependant, et oui, il y a toujours un problème (:pinch: ), je n'arrive pas à me connecter à l'interface !!!!

J'ai donc renommé mon fichier d'install, puis j'ai accédé à l'adresse de connexion utilisateur (/admin) et lorsque je rentre les logins (admin; password) qui sont par défaut, que je n'ai pas changés, ça ne fonctionne pas ! :angry:

Je n'ai pas eu ce soucis en local... Pourquoi moi ! :(

J'ai essayé de changé les logs dans config.php, ça ne change rien. Avez vous déjà eu ce pb ?

**EDIT

Bon, j'ai trouvé une solution, peut être pas la plus simple :silly:

Étant donné que mon local fonctionnait, je suis allé sur mon serv distant (phpmysql), j'ai supprimé la base _user, et j'ai uploader celle de mon local. Me voilà avec mes logs qui fonctionnent sur mon serv distant...

Magie :laugh:
Last Edit: 5 years 1 month ago by nanal. Reason: SOLUTION BRUTE
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61653

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2784
  • Thank you received: 365
  • Karma: 78
Si ça marche c'est parfait, mais juste pour avoir une réponse plus rapidement si tu as un autre problème :

Il faut savoir que "ça ne fonctionne pas !" ça ne veut rien dire. Qu'est-ce qui se passe, un message d'erreur, rien, absence de réaction du système, etc.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61660

  • nanal
  • nanal's Avatar
  • Offline
  • Junior Lime
  • Posts: 20
  • Karma: 0
""ça ne fonctionne pas !" ça ne veut rien dire." : a non, pas d'accord ;)

Pour préciser, la procédure normal suivant l'installation, qui est de renommer le répertoire d'installation puis d'accéder à l'adresse monsite/limesurvey/admin, n'a pas été réalisée avec succès.

Pourquoi ? Le login et le mdp étant par défaut admin / password, cela ne devrait pas créer de soucis. Cependant, un fois ces identifiants rentrés dans les bonnes cases avec la bonne orthographe puis le bouton "valider" cliqué, limesurvey me fait remarquer que les logins ne sont pas bons.

Si jamais il y avait eu un message d'erreur atypique à ce stade, je l'aurais précisé.

Excusez moi de ne pas avoir précisé cette étape cruciale. En effet, j'aurais pu ne pas effectuer la procédure habituelle. Mais ayant précisé auparavant que j'avais précédemment réalisé l'installation en local sans encombre cette précision ne m'a pas effleuré l'esprit.

Peut être que je me trompe là encore et que l'installation en locale est certes plus simple que sur un serveur distant et que malencontreusement, j'ai oublié une étape. (?)

Si le fait est avéré, veuillez me remettre dans le droit chemin afin d'éviter toute pratique inutile.

J'aimerais ne pas avoir à refaire cette manipulation, car si je n'avais pas eu d'autre limesurvey d'installé, je serais encore bloqué et sans aide.

Avez vous une idée ?

Merci d'avance pour tous ceux qui rencontrerons le même soucis. Même si c'est sans doute une erreur ou un oubli de ma part, comme dans beaucoup de cas.

Cette longue explication n'est pas ironique à tendance sarcastique, je voulais juste expliquer concrètement le problème rencontré :blink:
The administrator has disabled public write access.

Souci d'installation ? 5 years 1 month ago #61662

  • Nickko
  • Nickko's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 2784
  • Thank you received: 365
  • Karma: 78
"""ça ne fonctionne pas !" ça ne veut rien dire." : a non, pas d'accord"

C'est au choix, mais si je n'ai que cette info, moi tout ce que je peux répondre c'est "ça fonctionne" parce que chez moi ça fonctionne.

Mais bon, après c'est sûr, je n'ai pas trop l'habitude de faire de l'assistance utilisateur, je peux me tromper :-p


Pour en revenir à ta question :

Après mise à jour, le mot de passe, est celui que tu avais choisi avant. Il n'est pas réinitialisé.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.245 seconds
Imprint                   Data Protection Statement                  Revocation information and revocation form