Check out the LimeSurvey source code on GitHub!
Welcome, Guest
Username: Password:
  • Page:
  • 1
  • 2

TOPIC: Unable to remove "This question is mandatory" text

Unable to remove "This question is mandatory" text 2 years 6 months ago #106521

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6321
  • Thank you received: 1407
  • Karma: 547
Well, I don't have an answer - it's gotta be a bug.

The bad news is that there are no more bug fixes for LS 2.0. The good news is that it only happens when reviewing the group, not when executing the survey.


.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 2 years 6 months ago by tpartner.
The administrator has disabled public write access.

Unable to remove "This question is mandatory" text 2 years 6 months ago #106522

  • Rramjet
  • Rramjet's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Yes, the good news is it does not affect the execution! It is merely annoying when trying to get a sense of design and feel for the user experience of that section. Now I will go and find out if I add another group if the behaviour promugates or is confined to just the second group. I'll get back to you on that ASAP and then we can close this discussion I guess.


ETA: Nope, doesn't promulgate to a newly created group. It is specific to just that second group.

So, Now I will leave you with the conundrum (sorry 'bout that!) and thank you formally for your time (I appreciate it very much) and i will decide whether it is worth my while recreating the group as new or to just live with the inconvenience...

Is there a way of the poster marking a post to indicate that the issue has been resolved / not resolved but still concluded / not solved action still required (or similar) ?
Last Edit: 2 years 6 months ago by Rramjet. Reason: Edited to add
The administrator has disabled public write access.

Unable to remove "This question is mandatory" text 2 years 6 months ago #106535

  • Rramjet
  • Rramjet's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
More information:

I created a whole new section (group 2 made from scratch). It previewed and tested perfectly. Then I deleted the existing group 2 (ostensibly the one with the bug in it) and re-ordered the new group into the old gropup 2 position. Then the bug reappeared!!! So it has something to do with the POSITION - not the content -no matter what is in that position - it will have the bug in it.

I know you say there are to be no more bug fixes for LimeSurvey version 2 ...but you will need to fix it in the next version surely?
Last Edit: 2 years 6 months ago by Rramjet.
The administrator has disabled public write access.

Unable to remove "This question is mandatory" text 2 years 6 months ago #106540

  • DenisChenu
  • DenisChenu's Avatar
  • Online
  • Moderator Lime
  • Posts: 9353
  • Thank you received: 1341
  • Karma: 386
Really strange issue ...

Can you provide the lss file example or a link to the survey ?

Denis
PS: your LimeSurvey version please .
Assistance on LimeSurvey forum and LimeSurvey core developpement are on my free time (Say thanks ?).
A bug not reported is a bug not corrected. | Please, read the documentation | La doc en français à besoin de vous
The administrator has disabled public write access.

Unable to remove "This question is mandatory" text 2 years 6 months ago #106549

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 6321
  • Thank you received: 1407
  • Karma: 547
Hi Denis, the group is attached above and I can reproduce the problem on 2.0 - 131206.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The administrator has disabled public write access.

Unable to remove "This question is mandatory" text 2 years 6 months ago #106554

  • Rramjet
  • Rramjet's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Hi again - More info...

I have added some conditions to three of the questions in the group (visible only if the first equals yes) and the behaviour of the group is just what it should be in test mode (even when it is either the first question that is missed or one of the questions with the conditions or any other question or multiples thereof). In other words, the bug in group 2 position's preview mode that creates the "This question is mandatory" text does not seem to affect how the survey acts or reacts under test conditions (and hopefully won't when we go live).

Thankfully then it does not seem to be a fatal bug, however, that being stated, there was one test I did that proved fatal for the survey (when the initial question was missed) - and that was the first test after I recreated, deleted and repositioned (as in my previous post). The survey got stuck in a "This question is mandatory" loop and no matter what I selected or deselected in that group 2, it would not move on - and I was forced to close the survey altogether . However I cannot repoduce that behaviour and after that little scary moment all seems fine ...
Last Edit: 2 years 6 months ago by Rramjet.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.341 seconds
Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form