Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi
  • Page :
  • 1
  • 2

SUJET : Loss of Permissions Tool Bar - Please Help (Correction to earlier post)

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101298

  • georgebradford
  • Portrait de georgebradford
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Remerciements reçus 1
  • Karma: 1
Hi c-schmitz,

Let me answer your question by breaking down what I've done and what I see on my end.

I've overwritten all the files (I redid this without excepting any file anywhere in my configuration) using the latest build (131031).

The result is that...

1) The permissions tool bar is now available (see first attached image - ScreenShot003), which now allows me to change and save my password. (I've only been able to access my site by using the Forgot Password function.) It also would now allow me to do a backup of my installation, which I could not do before since I didn't have access to the tool bar.

2) The drop-down access to the different surveys still show all my surveys (see second attached image - ScreenShot005). If I choose any of them, I get the overview display (see third attached image - ScreenShot006). If I then select any of those surveys, nothing happens - I still only get the overview display.

This is why I wrote that somehow the link to the tables is broken because it doesn't bring up the detail view of a particular survey, where edits, exporting, reporting, and all of that can be done.

3) I notice that even though I uploaded build 131031, the window still reports the old build I had previously (121101).

So I can't access any of my running surveys.

Does this clarify a bit better?

If you or anyone else out there can help, please please do. It's a scary situation for me at the moment because of this.

Thank you,

-George

ScreenShot003:

hd17cee9.png


ScreenShot005:

h4ce5de1.png


ScreenShot006:

h1d922fb.png
Dernière édition: il y a 1 an 3 semaines par georgebradford.
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101303

  • c_schmitz
  • Portrait de c_schmitz
  • Hors ligne
  • LimeSurvey Team
  • Messages : 823
  • Remerciements reçus 116
  • Karma: 93
Yes, that clarifies it.
Though I am getting tired of telling you to overwrite the config directory - would you please just do it? Your refusal to overwrite it is the reason for the old build number.
Also it looks like you still did not properly upload all files. If you are using FTP make sure you are uploading the files in binary mode and make sure that the upload really completes successfully for all files.
Support us, too. Donate to the LimeSurvey project and help keep us going!
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101304

  • georgebradford
  • Portrait de georgebradford
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Remerciements reçus 1
  • Karma: 1
c_schmitz,

In my last post, I wrote that I overwrote the config directory. Before that post, I redid the overwrite for everything in my LS directory. I have not refused your suggestions.

Tell me what file is causing it to show as the old build number. Or what other files may be causing this. By your comments, I am guessing that an old file remains that is causing this, but I do not know which. This would be a file that does not exist in the new build but exists in my configuration, and I am unsure which file it might be or where - although my guess is that it is in the config directory.

Regarding your last comment, I uploaded the full zip directory and extracted everything. I then moved all the resulting directories and their contained files into my active LS directory.

-George
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101305

  • c_schmitz
  • Portrait de c_schmitz
  • Hors ligne
  • LimeSurvey Team
  • Messages : 823
  • Remerciements reçus 116
  • Karma: 93
Sorry, I misread.
But though you claim that you overwrote all files the old build number does show that you did not (the file specifically for this would be /application/config/version.php).
But if that file was not overwritten, how many files weren't probably too?
Support us, too. Donate to the LimeSurvey project and help keep us going!
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101306

  • georgebradford
  • Portrait de georgebradford
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Remerciements reçus 1
  • Karma: 1
That is a good question (ie, files that weren't overwritten). I have no way of knowing.

I guess that leads to the general update strategy for LS... if I copy all of my LS directory to another directory for safe keeping, and install clean the new build, will it work? Is this the general strategy for updating from one build to the next? That there are no files specific to an LS instance that are needed to make it work?

When you do this, where do the new files get the database (tables) login details and the images etc that belong to the surveys I am currently running?

I don't know how it all works, but I am doing my best to learn it.

-George
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101307

  • georgebradford
  • Portrait de georgebradford
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Remerciements reçus 1
  • Karma: 1
Do you suggest I empty my current LS directory and fill it with the new build?

-George
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101312

  • georgebradford
  • Portrait de georgebradford
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Remerciements reçus 1
  • Karma: 1
c_schmitz,

Success! Good news...

I put everything in my current/active LS directory into a new, temp directory for safe keeping. Then I re-extracted the new build and set them into the empty yet current/active directory and tried logging in.

As expected, LS wanted to reinstall a completely new instance for this build. I went into my temp directory and copied the config.php file into the application>config directory. Then I copied everything from the upload directory and copied them into the current/active directory.

When I tried logging in, LS wanted to update the database connections, I complied, and everything was back to functional: the permissions tool bar, access to the surveys etc.

So that's great news and a great relief!

Thank you much for your help!

-George
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101315

  • c_schmitz
  • Portrait de c_schmitz
  • Hors ligne
  • LimeSurvey Team
  • Messages : 823
  • Remerciements reçus 116
  • Karma: 93
You are most welcome - and sorry again for the misunderstanding above.

Heh, I am glad this worked out for you :-).
Support us, too. Donate to the LimeSurvey project and help keep us going!
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101321

  • georgebradford
  • Portrait de georgebradford
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Remerciements reçus 1
  • Karma: 1
No worries c_schmitz. Such happens. The most important thing though is that it worked.

I wonder if there is any documentation that spells out this update process and how to protect the 2 items you need to keep an instance intact: the config.php file and the full upload directory?

I had thought there were more files in more places that would be modified in the course of running LS. But knowing this worked makes the update process fairly painless and simple.

Thanks again for stepping in and helping - couldn't have done it without that!

:-)

-George
L'administrateur a désactivé l'accès en écriture pour le public.

Loss of Permissions Tool Bar - Please Help (Correction to earlier post) il y a 1 an 3 semaines #101325

  • c_schmitz
  • Portrait de c_schmitz
  • Hors ligne
  • LimeSurvey Team
  • Messages : 823
  • Remerciements reçus 116
  • Karma: 93
Support us, too. Donate to the LimeSurvey project and help keep us going!
L'administrateur a désactivé l'accès en écriture pour le public.
  • Page :
  • 1
  • 2
Modérateurs: ITEd
Temps de génération de la page : 0.138 secondes
Donation Image