Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : URL rewrite working, but not working?

URL rewrite working, but not working? il y a 11 mois 3 semaines #101181

  • gabeguillen
  • Portrait de gabeguillen
  • Hors ligne
  • Fresh Lemon
  • Messages : 1
  • Karma: 0
We just installed a fresh copy of LimeSurvey (limesurvey200plus-build131022) on a LAMP setup and everything is working fine, but I cannot seem to get the URL rewrite to work correctly. It works, and it doesn't work which means:

If I go to the main site (lets just say survey.domain.tld), there are links to surveys. If I check the link to a survey, it is linking to survey.domain.tld/index.php/476188/lang/en. However, if I take that link, remove the index.php and paste it back into the browser, survey.domain.tld/476188/lang/en works just fine.

Is there some setting somewhere that I am missing to turn this on? This server has .htaccess file lookup disabled for performance reasons, so the contents of the .htaccess file were merged into the VirtualHost block in the Apache configuration file. I have no reason to think that this is the issue, but here is the important snippet of the VirtualHost block:

<Directory /path1/path2/survey.domain.tld/>
Options +FollowSymLinks

<IfModule mod_rewrite.c>
RewriteEngine on

# if a directory or a file exists, use it directly
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

# otherwise forward it to index.php
RewriteRule . index.php
</IfModule>

# General setting to properly handle LimeSurvey paths
AcceptPathInfo on
</Directory>

We would like all the visible URLs to be nice and clean to match our other systems. Any help is appreciated.
Dernière édition: il y a 11 mois 3 semaines par gabeguillen.
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.117 secondes
Donation Image