Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : configuration with webserver authentication

configuration with webserver authentication il y a 1 an 2 mois #96410

  • jooghe
  • Portrait de jooghe
  • Hors ligne
  • Fresh Lemon
  • Messages : 9
  • Karma: 0
I'm a bit puzzled. We use webserver authentication (apache with Shibboleth ) with LS 1.91 without any problems. We put a proper .htacces file in the /admin directory. Users can logon and administer their surveys, respondents do go to the /admin folder so they don't need to login.

Now we are setting up a LS2 test installation. I've switched on webserver authentication and I only get it to work when I put a .htaccess file in the LS2 root folder, which requires users to login. But this means that respondents need to pass this authentication as well. When I remove it from the root folder and put it in admin/ or application/ directory, it fails to pick up the username. It's like th eauthentication is reroute to the root directory and that by doing this the user attributes are getting lost.

Is there some obvious mistake I'm making ? I'm still struggling a bit with the new YII structure.

Thanks.
L'administrateur a désactivé l'accès en écriture pour le public.

configuration with webserver authentication il y a 10 mois 3 semaines #99626

  • nohcho82
  • Portrait de nohcho82
  • Hors ligne
  • Junior Lime
  • Messages : 29
  • Karma: 0
I have the same problem. I cann't install the shibboleth on LS2.
Did someone find the solution?
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.165 secondes
Donation Image