Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Adding a language - Property "CDbCriteria.0" is not defined.

Adding a language - Property "CDbCriteria.0" is not defined. il y a 1 an 6 mois #91758

Hi hello!

I was keen to use the new build because there is a new language on there that I desperately need. However, when I try to add any language to my base English survey I get the error message
Property "CDbCriteria.0" is not defined.
. What's that about, and what can I do?
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Adding a language - Property "CDbCriteria.0" is not defined. il y a 1 an 6 mois #91762

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 341
  • Remerciements reçus 68
  • Karma: 38
The bug will be fixed in the next version. If you are in a hurry and want to edit the file yourself, check out this commit:
github.com/LimeSurvey/LimeSurvey/commit/...5c4c377351c61b844272
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: GalloiseBlonde

Re: Adding a language - Property "CDbCriteria.0" is not defined. il y a 1 an 6 mois #91776

Thank you mdekker, I may well give that a go. Love the UI on the latest build BTW.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Adding a language - Property "CDbCriteria.0" is not defined. il y a 1 an 5 mois #91832

Hi - it turns out there is another problem with secondary languages in the new build, which is that template changes and so on are only affecting the primary language. Annoyingly, this means my secondary language is appearing as question by question rather than in pages, and not using the template I redesigned with logos and stuff. Does anyone have any idea what's going on there?

PS: mdekker's alt worked perfectly!
Dernière édition: il y a 1 an 5 mois par GalloiseBlonde.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Adding a language - Property "CDbCriteria.0" is not defined. il y a 1 an 5 mois #91833

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 341
  • Remerciements reçus 68
  • Karma: 38
Probably your second language has no settings. Try changing texts for the language, that should fix your problem. If not, I think it will be fixed in the next build since some changes related to this have been done. The next build will probably be released later today (when we find no big issues)
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: GalloiseBlonde

Re: Adding a language - Property "CDbCriteria.0" is not defined. il y a 1 an 5 mois #91835

I reckon I'll wait for the new build then, if it's coming so soon. Thank you so much: your responses here have been very impressive. I'm glad I chose Limesurvey.
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.191 secondes
Donation Image