Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Error when viewing results: "Couldn't get answer type L - getAnswerCode()"

Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90446

  • ranman22
  • Portrait de ranman22
  • Hors ligne
  • Fresh Lemon
  • Messages : 4
  • Remerciements reçus 1
  • Karma: 0
I upgraded to the latest version of LS this morning. I went to go view the results of a survey that I currently have running, and I get the following error:

Couldn't get answer type L - getAnswerCode()

and it only shows 1 response (out of 79).

Any thoughts?

Thanks!

-Randy
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90447

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 340
  • Remerciements reçus 68
  • Karma: 38
You probably deleted an answer code that was used in a response already
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90448

  • ranman22
  • Portrait de ranman22
  • Hors ligne
  • Fresh Lemon
  • Messages : 4
  • Remerciements reçus 1
  • Karma: 0
Thank you for the repsonse.

I don't believe I have deleted anything. Things were working fine, and then I did the upgrade. If I click on "statistics", I can see all the responses in that format just fine.

-Randy
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90449

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 340
  • Remerciements reçus 68
  • Karma: 38
Could you open a bug report and attach your survey and results to it? Ofcourse you can mark it private so only developers can see your survey and results.

I tried to reproduce and got the error after i deleted one of the answer options after it had been used in a response. Can you export to excel and show the complete answers (instead of just the codes) without an error?
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90483

Hi there,

we have the same problem here.

We did no upgrade in the meantime (Version 2.00+ Build 121220) and did no changes to the survey.

As you can see by the attached screenshot parts, the data has gaps, randomly stops and most of all isn´t shown at all.

To answer your question to ranman, it is possible to download the data to excel correctly.

[attachment:2]Fehler Intquest.jpg[/attachment]

Please let me know what to do.

Thx, Andre
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90485

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 340
  • Remerciements reçus 68
  • Karma: 38
The error seems to be in 'other' and 'comment' fields too. Due to christmas the release schedule is a little messed up. Not sure if there will be a new release this week but if you urgently need it, you can download the source from github.
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90539

  • Mazi
  • Portrait de Mazi
  • Hors ligne
  • LimeSurvey Team
  • Messages : 5279
  • Remerciements reçus 289
  • Karma: 246
This problem is already fixed. A new bugfix release will be available next week.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Error when viewing results: "Couldn't get answer type L - getAnswerCode()" il y a 1 an 3 mois #90555

  • ricardo
  • Portrait de ricardo
  • Hors ligne
  • Expert Lime
  • Messages : 108
  • Remerciements reçus 1
  • Karma: 0
Is there a way to fix this momentarily without having to wait until next week? I have an active survey and participants are getting the "Couldn't get answer type L - getAnswerCode()" when trying to submit the survey. This happens when they select "other" in one of the questions.
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.136 secondes
Donation Image