Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : No Login Screen

No Login Screen il y a 1 an 3 mois #90313

  • rmiddleton
  • Portrait de rmiddleton
  • Hors ligne
  • Fresh Lemon
  • Messages : 4
  • Karma: 0
New install. Windows server 2008 R2, IIS 7.5. Server was setup for and running Wordpress. Everything seemed to go okay with the install, but there is no login page available.
This: websites.msdpt.k12.in.us/limesurvey/admin/admin.php
Becomes: websites.msdpt.k12.in.us/limesurvey/index.php/admin
when typed in the URL.
The admin folder only has admin.php & index.php and they are just redirects.
And is the list of surveys page (of course, there are none).
Have read through doc's and forums and not finding the answer. Had to have missed something.
Looking at the MySQL database (with phpmyadmin) I see the admin user is created but other tables are all empty. Which, should probably be true at this point.
File permissions set, per manual, for Everyone, IIS_Users, Default App Pool (not in doc's but worth a shot).
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90328

  • renfred
  • Portrait de renfred
  • Hors ligne
  • Fresh Lemon
  • Messages : 1
  • Karma: 0
SAME HERE.....!!

I found this topic is not new in the forum but seems no good or real answer to solve the problem!! Would admin please help to advice what we should do to fix the problem?

Thanksssssss!
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90333

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 340
  • Remerciements reçus 68
  • Karma: 38
try index.php?r=admin

the /admin/admin.php and /admin/index.php redirect to the apache style url that does not work with IIS. We will fix this is the next version

bugs.limesurvey.org/view.php?id=7107
---
Menno Dekker
Dernière édition: il y a 1 an 3 mois par mdekker.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90383

  • rmiddleton
  • Portrait de rmiddleton
  • Hors ligne
  • Fresh Lemon
  • Messages : 4
  • Karma: 0
Thank you. That does bring up a login page and allow me to login as Admin. That's all it accomplished though. Cannot add users, surveys, groups, etc. No error message, just blanks the entries. Back to the research I guess.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90420

  • DenisChenu
  • Portrait de DenisChenu
  • En ligne
  • Moderator Lime
  • Messages : 5837
  • Remerciements reçus 713
  • Karma: 222
Maybe, look at your application/config/config.php for
[code type=php-brief] 'urlManager' => array(
'urlFormat' => 'path',
'rules' => require('routes.php'),
'showScriptName' => true,
),[/code]
And set it to:
[code type=php-brief] 'urlManager' => array(
'urlFormat' => 'get',
'rules' => require('routes.php'),
'showScriptName' => true,
),[/code]

Denis
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90433

  • rmiddleton
  • Portrait de rmiddleton
  • Hors ligne
  • Fresh Lemon
  • Messages : 4
  • Karma: 0
Thank you for the reply. Applied. No change. Still cannot add users, surveys, etc. Show PHPinfo just flashes. PHP is 5.2.17 on Windows 2008 R2. I suspect it is a PHP problem, but no clue how to solve.
phpinfo() output attached
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90436

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 340
  • Remerciements reçus 68
  • Karma: 38
Now go to your config.php file again and at the bottom you see debug and debugsql they are probably both 0. Set them to 2 and 0 respectively. Do you get any errors now?
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90437

  • rmiddleton
  • Portrait de rmiddleton
  • Hors ligne
  • Fresh Lemon
  • Messages : 4
  • Karma: 0
No change.
// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
'debug'=>2,
'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2

BTW: websites.msdpt.k12.in.us/limesurvey/index.php?r=admin
Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. if you want access
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90459

I also have installed LimeSurvey 2.x on a Windows 2008 Server.
With IIS and MySQL.

I do encouter exact the same problems:
1)No login screen
2)Not possible to load surveys, create surveys or to add new question groups / new questions.

Regards,
Robert
L'administrateur a désactivé l'accès en écriture pour le public.

Re: No Login Screen il y a 1 an 3 mois #90464

  • mdekker
  • Portrait de mdekker
  • Hors ligne
  • LimeSurvey Team
  • Messages : 340
  • Remerciements reçus 68
  • Karma: 38
rmiddleton solved his problem by installing the latest version, please do a fresh download and overwrite the files.
---
Menno Dekker
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.149 secondes
Donation Image