Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Godaddy Installation problem

Godaddy Installation problem il y a 1 an 4 mois #89724

  • jbsarma
  • Portrait de jbsarma
  • Hors ligne
  • Fresh Lemon
  • Messages : 1
  • Karma: 0
I have limesurevy version 2 installed at http://www.learnandshare.net/limesurvey on Godaddy's Linux shared server but when I go to admin page http://www.learnandshare.net/limesurvey/index.php/admin I get an error 'No input file specified.'

I got the following reply from the GoDaddy's support 'When visiting your site and reviewing the files and directories of your application, there appears to be a redirect issue. As such, when visiting www.learnandshare.net/limesurvey/index.php/admin, the files and directories are not being referenced properly. As such, you may need to ensure that the admin directory is being properly referenced on your site. When visiting your site, it is visible and navigational. As such, there are no issues with the hosting plan or the server it resides on.'
It was not helpful as I expected some solution as to the configuration of .htaccess file. Does anybody has any experience of installing Limesurvey 2 (latest build as on 5th Dec 12) on GoDaddy's Linux server. Thanks in advance.
Dernière édition: il y a 1 an 4 mois par jbsarma.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Godaddy Installation problem il y a 1 an 4 mois #89740

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 5854
  • Remerciements reçus 716
  • Karma: 222
Dernière édition: il y a 1 an 4 mois par DenisChenu.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Godaddy Installation problem il y a 1 an 3 mois #90588

  • kit
  • Portrait de kit
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
I couldn't get this to work either on Godaddy. Everything uploaded ok to the site using FileZilla (tried it twice) and the install would go smoothly until creating the admin account. Then the install bombed with the "No input file specified." error and there was no user in the lime_users db table.

I also would get the error when I attempted to navigate to /limesurvey/index.php/admin/.

I searched the forums and found a thread saying that FastCGI was to blame. After much frustration, I finally caved and changed the option: Hosting -> File Extensions Management -> .php extension changed from "PHP 5.3.x FastCGI" to "PHP 5.2.x". I deleted limesurvey/application/config, dropped all the tables in my DB, and went to /limesurvey/index.php/installer/welcome. This time, the installer worked and I was able to login.

I can currently reproduce the issue on the site by changing the file extension option and attempting to navigate to /limesurvey/index.php/admin. Is there anymore information I can provide in order to troubleshoot?
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Godaddy Installation problem il y a 1 an 3 mois #90656

  • haniar
  • Portrait de haniar
  • Hors ligne
  • Fresh Lemon
  • Messages : 7
  • Karma: 0
I am having the same problem on godaddy. I tried your suggestion of 5.2 but only Fast CGI option is available with it. It did not work. Anything else I should watch for.

I have loaded the zipped file and unzipped in file manager. I suspect something has gone wrong with permissions in the unzipping process
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Godaddy Installation problem il y a 1 an 1 mois #93205

  • kit
  • Portrait de kit
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
Ok I think I finally figured it out. You can use PHP 5.3 with a small tweak.

First, validate you have PHP 5.3 set in your Godaddy web hosting control panel,
  • Under More -> Programming Languages validate it is set to PHP 5.3.
  • Under More -> Programming Languages validate the .php extension is set to PHP 5.3.x FastCGI.
The root of the issue is that there is a php configuration setting, cgi.fix_pathinfo, which should be 1 by default. On Godaddy's servers this is set to 0!

Create a new file in the ROOT of your Godaddy server named php5.ini and put inside of it:
cgi.fix_pathinfo=1

Works for me!
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.138 secondes
Donation Image