Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : upgrading from 1.92 to 2.00 getting white screen on initial run

upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89609

  • tbaker
  • Portrait de tbaker
  • Hors ligne
  • Fresh Lemon
  • Messages : 9
  • Karma: 0
I am upgrading from 1.92 to 2.00
I have downloaded the latest 2.0
renamed my old limesurvey and unzipped the latest in the directory
I chg'd permissions (777) on tmp, copied my old upload and chg'd permissions (777) on upload dir
i run the ...limesurvey/admin it redirects me to ... limesurvey/index.php/admin and noting shows except a whitescreen

I have checked apache no errors...
i have looked at console and no errors

Can anyone help on this?
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89618

  • jelo
  • Portrait de jelo
  • Hors ligne
  • Platinum Lime
  • Messages : 467
  • Remerciements reçus 52
  • Karma: 16
tbaker écrit:
i have looked at console and no errors

What did you do on the console to check errors?

Did you have a backup of your database?
Did you manage to see the installer after coping LS2.0 on the server?

If the installation went wrong, you might try a fresh installation in a different directory with a new database to see if the server is compatible.

Or you backup application/config/config.php and delete the file and try to run the installer again. If you always used the same database you might have mixed tables in it.
You might clean the database by hand or restore your database backup first.

Personally I would never do an upgrade without having tested a fresh installation first.
You always need a fallback if you're running LS in a productive way. And with an direct upgrade you risk you're best known installation becoming unavailable.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Aw: upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89671

  • tbaker
  • Portrait de tbaker
  • Hors ligne
  • Fresh Lemon
  • Messages : 9
  • Karma: 0
we are performing this upgrade on a DEV instance so are DB and Production instances are protected, DEV instance runs on the same server as prod so environment and infrastructre are identical ....
I have isolated the error to the below:

URL Method Result Type Received Taken Initiator Wait‎‎ Start‎‎ Request‎‎ Response‎‎ Cache read‎‎ Gap‎‎
prod.medimix.biz/DEVLMS/limesurvey4/index.php/admin GET 200 text/html 190 B 78 ms refresh 0 31 47 0 0 41

at this line the application hangs:
Yii::createApplication('LSYii_Application', APPPATH . 'config/config' . EXT)->run();

please advise

I have also tried on a clean instance fresh install same server ; results are the same...
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: Re: Aw: upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89682

  • jelo
  • Portrait de jelo
  • Hors ligne
  • Platinum Lime
  • Messages : 467
  • Remerciements reçus 52
  • Karma: 16
Good to know that no productive system is damaged.

Did you take a look at application/config/config.php to see if the file is correctly written? Is the directory /tmp/runtime writable?

Is a fresh install working? Only the upgrade fails?
Normally I would delete /application/config/config.php and drop the database and do retry the installer. Or get a fresh old database to be sure that the database wasn't messed up during the first attempt to upgrade.

If you focus on the upgrade routine I would open a ticket in the bug tracker to see if developers can help you.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89728

  • tbaker
  • Portrait de tbaker
  • Hors ligne
  • Fresh Lemon
  • Messages : 9
  • Karma: 0
Problem resolved with patch "Dev Renamed HTTPRequest class due to possible name collisions"
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: Re: upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89729

  • jelo
  • Portrait de jelo
  • Hors ligne
  • Platinum Lime
  • Messages : 467
  • Remerciements reçus 52
  • Karma: 16
Is the patch related to a bug tracker ticket? Can you post where to get the patch?
Is it in the last update?
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Aw: Re: upgrading from 1.92 to 2.00 getting white screen on initial run il y a 1 an 8 mois #89730

  • tbaker
  • Portrait de tbaker
  • Hors ligne
  • Fresh Lemon
  • Messages : 9
  • Karma: 0
here is where the patch was identified ...
not sure if it is in the latest release yet
github.com/LimeSurvey/LimeSurvey/commit/...8f0ba82407a91a5bbeea
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.131 secondes
Donation Image