Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : 404 Error

404 Error il y a 1 an 8 mois #88981

  • g3guy
  • Portrait de g3guy
  • Hors ligne
  • Fresh Lemon
  • Messages : 14
  • Karma: 0
Hi All

I've installed and reinstalled Limesurvey (Version 2.00+ Build 121121) - uploaded in binary format - and still encounter the same error.

It basically occurs when trying to change the "End message:" of my survey. The error:

>>>

Forbidden

You don't have permission to access /survey/index.php/admin/database/index/updatesurveylocalesettings on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

>>>

What folder should I change the permissions on?

Thanks,
Adam
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: 404 Error il y a 1 an 8 mois #88984

  • jelo
  • Portrait de jelo
  • Hors ligne
  • Platinum Lime
  • Messages : 467
  • Remerciements reçus 52
  • Karma: 16
Permission settings are depending on the Webserver PHP Stack.
So your provider might offer some help about what permissions are expected on files and folders.

Since the error message in your brownser isn't offering any direct hint where to look for permission problems the best way is to look at the logfiles of the webserver and/or the error.logs of php.
Where they are stored is up the the configuration of the webserver/PHP stack.

You can activate the debug messages from limesurvey via a config.php file.
Look at the config-sample.php under application\config
The documentation about the configuration can be found here
docs.limesurvey.org/Optional+settings&st...tions+for+LimeSurvey
L'administrateur a désactivé l'accès en écriture pour le public.

Re: 404 Error il y a 1 an 8 mois #88985

  • g3guy
  • Portrait de g3guy
  • Hors ligne
  • Fresh Lemon
  • Messages : 14
  • Karma: 0
Thanks jelo!

I'll chat to my hosting guys as well as checking out the debug option too. Will revert.
L'administrateur a désactivé l'accès en écriture pour le public.

Re: 404 Error il y a 1 an 8 mois #88987

  • g3guy
  • Portrait de g3guy
  • Hors ligne
  • Fresh Lemon
  • Messages : 14
  • Karma: 0
A quick response from my guys indicated that the mod_security was being triggered. They simply whitelisted the rule as everything is working now.

Thanks again!
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.136 secondes
Donation Image