Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : LimeSurvey behind Proxy

LimeSurvey behind Proxy il y a 2 ans 3 mois #77916

  • dreier
  • Portrait de dreier
  • Hors ligne
  • Junior Lime
  • Messages : 24
  • Remerciements reçus 2
  • Karma: 3
Hello Community,

I have actually planned to get LimeSurvey productive in our company. Actually i am restricted to install LimeSurvey 1.92+ Build 120319 on a machine in a local network. Now i got a configuration of a reverse proxy server which is directing on my local server.
Now the proxy redirects to my server without any problem. I can login (via Webserver login) and get into LimeSurvey. But now i am unable to do anything:
If I try to make something, I get on a new Site which tells me "Reloading screen. Please wait." and I get on this site again and again - it loads - done -loads - done...but never get anywhere else.
If I try to use the normal login, I can't even login, I just get redirected to the login site without any information.
So my question is: Is there anything wrong with our proxy server, or do we have to be patient about any configuration in LimeSurvey to use it behind a proxy?

Regards
dreier
Dernière édition: il y a 2 ans 3 mois par dreier.
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: LimeSurvey behind Proxy il y a 2 ans 3 mois #77929

  • dreier
  • Portrait de dreier
  • Hors ligne
  • Junior Lime
  • Messages : 24
  • Remerciements reçus 2
  • Karma: 3
Update:
After changin the "rooturl" in the config to the proxy-url and deleting the browsercache (which i did for sure just after 1hour testing..) the Admin-Site is working fine!
But there is still a problem left: I cannot answer a survey - I can reach the Welcome-Site but by clicking the next button I get to the survey overview site.

Actually I redirect from https to http - could that be the problem? This configuration was not my idea, it was recommended by the proxy admin.

Regards,
dreier
L'administrateur a désactivé l'accès en écriture pour le public.

Re: Aw: LimeSurvey behind Proxy il y a 2 ans 3 mois #77937

  • Mazi
  • Portrait de Mazi
  • Hors ligne
  • LimeSurvey Team
  • Messages : 5300
  • Remerciements reçus 291
  • Karma: 247
This probably is caused by your weird configuration. Another source of trouble might be the server configuration. If there are too strict security settings, e.g. for the "suhosin" module, this might cause problems as well.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
L'administrateur a désactivé l'accès en écriture pour le public.

Re: LimeSurvey behind Proxy il y a 2 ans 3 mois #77940

  • dreier
  • Portrait de dreier
  • Hors ligne
  • Junior Lime
  • Messages : 24
  • Remerciements reçus 2
  • Karma: 3
Hey,

okay solved it by myself - was my mistake:
Have used the proxy as rooturl via http - after changing to https it worked.

Topic can be closed. Sorry for bothering your time.

Cheers
dreier
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: LimeSurvey behind Proxy il y a 1 an 4 mois #93571

  • charleslcso
  • Portrait de charleslcso
  • Hors ligne
  • Fresh Lemon
  • Messages : 17
  • Karma: 0
Which config file you are referring to? It is not in conf/config.php nor conf/limesurvey.conf.

I can't specify the URL when I create the survey….

Please tell me.
L'administrateur a désactivé l'accès en écriture pour le public.

Aw: LimeSurvey behind Proxy il y a 1 an 4 mois #93573

  • charleslcso
  • Portrait de charleslcso
  • Hors ligne
  • Fresh Lemon
  • Messages : 17
  • Karma: 0
I got it.

In config-defaults.php, change $config
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.136 secondes
Donation Image