Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Verlust der Bedingungen bei Import (2.05+ -> 1.91+)

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109521

Liebe LimeSurvey-Community,

aus Datenschutzgründen bin ich dazu gezwungen mit meinem Fragebogen den LimeSurvey-Server zu wechseln.
Leider gehen beim Import jedoch alle Bedingungen flöten :(.

Ich gehe davon aus, dass dies durch die unterschiedlichen LimeSurvey-Versionen bedingt ist.
Version 2.05+ Build 140302 ----> Version 1.91+ Build 12416
Leider ist jedoch im Moment ein Update der veralteten Version von den Admins nicht vorgesehen.

Oder hängt es vielleicht damit zusammen, dass Token-Bedingungen in der alten Version nicht funktionieren?
Bspw. {if (TOKEN:ATTRIBUTE_34 =='Z',TOKEN:ATTRIBUTE_12 ,' ')} in einer Fragegruppenbeschreibung wird so wie es ist, als Text, angezeigt.

Habt ihr vielleicht eine Idee wie ich dieses Problem umgehen könnte?
Gerne auch mit irgendeinem Workaround. Alles wäre schneller als die Bedingungen händisch
nachzutragen ;).

Vielen lieben Dank für eure Hilfe!!
Liebe Grüße
Josi
L'administrateur a désactivé l'accès en écriture pour le public.

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109526

  • holch
  • Portrait de holch
  • Hors ligne
  • LimeSurvey Team
  • Messages : 2851
  • Remerciements reçus 358
  • Karma: 124
Das ist ungefähr damit zu vergleichen, ein für Windows 8 geschriebenes Programm auf Windows 95 laufen zu lassen.

Wenn ich das richtig sehen, verwendest du den Expression Manager, richtig?

Schau mal hier, vielleicht ist das ja dein Problem: manual.limesurvey.org/Expression_Manager...s_EM_with_1.91.2B.3F
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: JosiBacchantes

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109577

Vielen Dank für die schnelle Antwort holch!

Ja, das mit Windows scheint mir ein sehr guter Vergleich, so fühlt es sich auch an, schrecklich!

Auch wenn ich nicht wusste wies heißt, hab ich scheinbar tatsächlich den Expressions Manager benutzt.

Der von dir verlinkte Abschnitt schildert zwar nicht mein Problem, aber der ganze Wiki-Eintrag hat mir geholfen mein Problem zu verstehen: In der alten Limesurvey-Version gibts noch keinen Expression-Manager. Das führt auch dazu, dass ohne JavaScript das ausführen von bspw. 'Tailoring' (z.B. Mr/Mrs je nach vorheriger Geschlechtsangabe) nicht möglich ist.

Es gäbe also zwei Wege das Problem zu lösen:
1. Ich programmier die Bedingungen und das Tailoring in Java oder
2. ich erwirke, dass endlich auf die nächste Version umgestiegen wird.
Beides leider mehr als kompliziert.

Oder hab ich doch was falsch verstanden und es gäbe eine Lösung?

Vielen Dank nochmal für die Hilfe!

LG Josi
L'administrateur a désactivé l'accès en écriture pour le public.

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109580

  • holch
  • Portrait de holch
  • Hors ligne
  • LimeSurvey Team
  • Messages : 2851
  • Remerciements reçus 358
  • Karma: 124
Kann mir vorstellen, dass das alles nicht einfach ist.

Offensichtlich kannst du ja nicht einfach auf einen anderen Server umsteigen.

Die Version 1.91 ist natürlich schon echt steinzeit und seitdem hat sich ja auch einiges getan im Bezug auf Funktionen und natürlich auch Sicherheit. Es ist also durchaus sinnvoll, dass der Server-Admin mal seinen Hintern bewegt und die neueste Version einspielt. Vielleicht kannst du es ihm damit schmackhaft machen, dass die Updates dann wirklich nur noch ein paar Klicks sind... ;-)

Im Prinzip wäre es auch überhaupt kein Problem ein zweites System parallel aufzusetzen, wenn er Angst hat, dass irgendwas schief läuft. Mache ich auch regelmässig so.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: JosiBacchantes

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109621

  • jelo
  • Portrait de jelo
  • Hors ligne
  • Platinum Lime
  • Messages : 470
  • Remerciements reçus 52
  • Karma: 16
JosiBacchantes écrit:
aus Datenschutzgründen bin ich dazu gezwungen mit meinem Fragebogen den LimeSurvey-Server zu wechseln.
Aus Datenschutzgründen wechseln auf eine veraltete Limesurveyversion. Das hat was.
Da dürfte wohl auch Betriebsystem auf dem Server so alt sein, dass aktuelle LS-Anforderungen an PHP und Datenbank nicht erfüllt sind. Damit würde eine parallele Installation wohl auch nicht gehen.

Universitäres oder privatwirtschaftliches Umfeld?

Ich würde das nicht umprogrammieren wollen. Bei solchen Spielchen wird immer was übersehen. Am Ende sind dann wichtige Daten nicht korrekt erfasst. Dann redet keiner mehr vom alten Server.

Die Person, die entschieden hat, das der LS2.05 Server nicht dem Datenschutzniveau entspricht, sollte ja auch was zur Situation Server alte Version sagen können.
Würde nicht mit LS selbst, sondern mit Betriebsystem und PHP-Version argumentieren. Je nach Betriebsystem werden zwar auch alte PHP Versionen geflickt, aber meist findet sich eine lange Liste an Sicherheitslücken, die doch in der Datenschutzbegründung Berücksichtigung finden sollten.
Z.B. hier www.cvedetails.com/version/36749/PHP-PHP-5.1.6.html
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: JosiBacchantes

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109625

Vielen Dank für euere Antworten!
Es handelt sich um universitäres Umfeld und universitäre Mühlen mahlen laaangsam.
Es gibt zwar einen Plan, dieses Jahr noch auf eine neue Version umzusteigen, aber das ist noch etwas hin.
Jedenfalls versuche ich tatsächlich gerade zu erwirken, dass sie für die Studie eine kleine Parallelinstallation aufsetzen.

@jelo Vielen Dank für den PHP-Tip, das werde ich auf alle Fälle als zusätzliche Argumentation verwenden, falls sie sich nicht recht überzeugen lassne.
L'administrateur a désactivé l'accès en écriture pour le public.

Verlust der Bedingungen bei Import (2.05+ -> 1.91+) il y a 4 mois 2 semaines #109631

  • jelo
  • Portrait de jelo
  • Hors ligne
  • Platinum Lime
  • Messages : 470
  • Remerciements reçus 52
  • Karma: 16
Mein Link ist nur ein Beispiel (PHP-Version auf Deinem Server gilt es herauszufinden). Weiß nicht, ob in der alten LS-Version auch schon der PHP-Info Button war, um sich die Serverinfos anzeigen zu lassen.

Falls Du nicht an der Nase herumgeführt werden willst, lass Dir die Serverinfos vom alten Server schicken. Vermutlich hast Du es ja mit Fakultäts- und InstitutsIT zu tun. Die Uni-IT dürfte eigentlich ein paar mehr Server und Leute am Start haben. Viel Erfolg.
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: JosiBacchantes
Modérateurs: ITEd
Temps de génération de la page : 0.142 secondes
Donation Image