Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Problèmes Conditions

Problèmes Conditions il y a 5 mois 4 jours #101644

  • lau972
  • Portrait de lau972
  • Hors ligne
  • Fresh Lemon
  • Messages : 6
  • Karma: 0
Bonjour,

Après avoir créer mon questionnaire, j'ai mis en place des conditions sur certaines questions.
Par exemple :

Montrer la question n°7 si la réponse est oui à la question 1

En testant mon questionnaire, les conditions ne sont pas appliquées.
Quelqu'un a-t-il déjà rencontré ce problème, si oui quelle est la solution.

Merci
L'administrateur a désactivé l'accès en écriture pour le public.

Problèmes Conditions il y a 5 mois 4 jours #101646

  • Nickko
  • Portrait de Nickko
  • Hors ligne
  • LimeSurvey Team
  • Messages : 1929
  • Remerciements reçus 218
  • Karma: 44
Bonjour,

Comment testes-tu ton questionnaire ?
Pourrais tu faire une copie d'écran de la condition s'il te plait.

Bienvenue sur le forum.
Nickko
Ergonome / Usability expert
L'administrateur a désactivé l'accès en écriture pour le public.

Problèmes Conditions il y a 5 mois 4 jours #101647

  • lau972
  • Portrait de lau972
  • Hors ligne
  • Fresh Lemon
  • Messages : 6
  • Karma: 0
merci pour ta réponse rapide.

je test mon questionnaire en cliquant sur l'icone "exécuter le questionnaire"

voici une capture d'écran de ma condition


h7b7802b.png



h749c3b6.png
Dernière édition: il y a 5 mois 4 jours par lau972.
L'administrateur a désactivé l'accès en écriture pour le public.

Problèmes Conditions il y a 5 mois 4 jours #101648

  • Nickko
  • Portrait de Nickko
  • Hors ligne
  • LimeSurvey Team
  • Messages : 1929
  • Remerciements reçus 218
  • Karma: 44
qu'entends-tu par "condition pas appliquée" la question est-elle toujours affichée ou au contraire, toujours masquée ?

Parce que si tu me dit qu'elle est toujours masqué et qu'elle ne s'affiche pas si tu choisis oui à la question 1, je te dirais que c'est normal et que c'est le sens de ta condition. Et je t'aiderais à la débugger.

Si tu me dis qu'elle est toujours affichée alors en effet ce n'est pas normal. Et là on devra continuer les investigations pour trouver la cause du problème.

Enfin tu es sûr que tu ne te trompe pas de question, tu parles de la question N°7 dans le premier message et tu me montres une copie des conditions de la question N°22.
Nickko
Ergonome / Usability expert
Dernière édition: il y a 5 mois 4 jours par Nickko.
L'administrateur a désactivé l'accès en écriture pour le public.

Problèmes Conditions il y a 5 mois 4 jours #101649

  • lau972
  • Portrait de lau972
  • Hors ligne
  • Fresh Lemon
  • Messages : 6
  • Karma: 0
J'ai trouver une solution.

J'ai appliqué la condition d'afficher les questions suivantes uniquement si la réponses est "non" aux trois premières questions. Du coup ca fonctionne comme çà.

Merci pour votre aide
Dernière édition: il y a 5 mois 4 jours par lau972. Raison: fautes
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: Nickko
Temps de génération de la page : 0.119 secondes
Donation Image