Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Export html et PDF

Export html et PDF il y a 1 an 1 mois #97034

  • Annieshec
  • Portrait de Annieshec
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
Bonjour

Je suis nouveau venu sur le forum.
J'ai fait deux installations de Lime sur des serveurs différents.
Sur l'un tout est Ok. Sur l'autre quand je suis dans la partie statistiques et que je veux faire une sortie Html avec graphique ou une sortie PDF, j'obtiens une page vide (et sans code source). Les sorties html sans graphique et excel, elles se passent très bien.

Si quelqu'un peut m'aider à avancer, je suis preneur

Jean-Louis
L'administrateur a désactivé l'accès en écriture pour le public.

Export html et PDF il y a 1 an 1 mois #97035

  • Nickko
  • Portrait de Nickko
  • Hors ligne
  • LimeSurvey Team
  • Messages : 2049
  • Remerciements reçus 246
  • Karma: 53
Quelles sont les différences entre les 2 serveurs ?
Nickko
Ergonome / Usability expert
L'administrateur a désactivé l'accès en écriture pour le public.

Export html et PDF il y a 1 an 1 mois #97036

  • Annieshec
  • Portrait de Annieshec
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
Ils ont d'après ce qu'en j'en sais tous les deux la même version de Débian. Sur celui qui ne renvoie pas les PDF GD est en version 2.0 sur l'autre elle est plus récente.

Jean-Louis
L'administrateur a désactivé l'accès en écriture pour le public.

Export html et PDF il y a 1 an 1 mois #97067

  • Nickko
  • Portrait de Nickko
  • Hors ligne
  • LimeSurvey Team
  • Messages : 2049
  • Remerciements reçus 246
  • Karma: 53
Tente une mise à jour de GD. Sinon, là comme ça je ne sais pas trop comment t'aider.
Nickko
Ergonome / Usability expert
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: Annieshec

Export html et PDF il y a 1 an 1 mois #97070

  • Annieshec
  • Portrait de Annieshec
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
Finalement, je viens de trouver le solution.
Ça fonctionne !!!
En comparant les deux PhpInfo, je me suis aperçu que le serveur sur lequel ça marchait avait un memory_limit à 128M et l'autre à 64M donc pas assez de ressources.
Dans le fichier .htaccess à la racine du dossier de limesuvey, j'ai rajouté la ligne « php_value memory_limit 128M »
et c'est bon.

:)
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: Nickko
Temps de génération de la page : 0.129 secondes
Donation Image