Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Problem with Ldap import from AD

Problem with Ldap import from AD il y a 1 an 1 semaine #100062

  • Donsson
  • Portrait de Donsson
  • Hors ligne
  • Fresh Lemon
  • Messages : 2
  • Karma: 0
I'm trying to get participants from active directory.
LimeSurvey binds to it ok and is working basicly correctly.

Problem is that when the group from whitch I try to import participant contains users whos name
contains umlauts (ä,ö, etc), the import crasches with error:

CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 1366 Incorrect string value: '\xE4\xE4' for column 'lastname' at row 1


If I select a group that has users without umlauts it works as it should.

Is there any workaround since changing users names is not an option?

Used version of Limesurvey 2.00+ (130923) stable
L'administrateur a désactivé l'accès en écriture pour le public.

Problem with Ldap import from AD il y a 1 an 6 jours #100083

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 6362
  • Remerciements reçus 827
  • Karma: 245
Hi,

Looking at application/config/LDAP.php, there are this information:
// Define the encoding used by the LDAP directory
// You may omit this parameter (let it commented out)
// as the default value, 'utf-8', should work for most installations.
// However, Active Directory in West Europe may use 'cp850'.
// $LDAP_server[$serverId]['encoding'] = 'utf-8';

Maybe you can try in your server config:
// Define the encoding used by the Ldap directory
// You may omit this parameter (let it commented out)
// as the default value, 'utf-8', should work for most installations.
// However, Active Directory in West Europe may use 'cp850'.
$ldap_server[$serverId]['encoding'] = 'cp850';

OR another encoding ...

Denis
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: Donsson

Problem with Ldap import from AD il y a 1 an 6 jours #100085

  • Donsson
  • Portrait de Donsson
  • Hors ligne
  • Fresh Lemon
  • Messages : 2
  • Karma: 0
Thanks

That guided me to right direction.
I got it work with utf-8 encoding and changing protocol to ldapv3
L'administrateur a désactivé l'accès en écriture pour le public.

Problem with Ldap import from AD il y a 1 an 6 jours #100132

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 6362
  • Remerciements reçus 827
  • Karma: 245
Maybe we can update a little the LDAP.file.

But i think by dfault is this settings ?
No ?
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.236 secondes
Donation Image