Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : welcome page translation not working

welcome page translation not working il y a 1 an 2 mois #97040

  • dleger
  • Portrait de dleger
  • Hors ligne
  • Fresh Lemon
  • Messages : 18
  • Karma: 0
I am having an issue with the translation for the welcome page. In the edit text elements section, I added the default language text (English) and added the French translation. However, aft activating the survey, only the English appears, even when I select the French link from the execute survey... Now, when I select the language with the switcher, after entering the token ( its closes access)... The welcome message is fine... But I need the proper language from the beginning...

Even when going to the URL for someone who has French language as their preference, and using the direct Lin from the token page, it appears in English.

I thought maybe because I added the translation after it was live was the reason, so I deactivated, re-entered the text, and tested... It worked... Then when I activated it, same issue again...

Could the fact that I have language in the token database be causing the issue? I'm out of ideas here.

Any ideas on what I can do / try to make this work? I'm a little desperate as I've been working on this for 8 hours now...
L'administrateur a désactivé l'accès en écriture pour le public.

welcome page translation not working il y a 1 an 2 mois #97051

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 6256
  • Remerciements reçus 799
  • Karma: 239
Hello,

Each token have a "language" set in the datatable. You have to update the language column according to token language.
going to the URL for someone who has French language as their preference
In the token table ? With the language set in url or not ?

Use another browser to test : because a lot of information are found in session.

Maybe you can test first without token.

Denis
PS: i receive your email, if we not able to find here : i recontact you.
Dernière édition: il y a 1 an 2 mois par DenisChenu.
L'administrateur a désactivé l'accès en écriture pour le public.

welcome page translation not working - disappearing il y a 6 mois 1 semaine #104990

  • LloydW
  • Portrait de LloydW
  • Hors ligne
  • Gold Donor
  • Messages : 32
  • Remerciements reçus 1
  • Karma: 0
I'm following up on this post because I have the opposite problem.

If I put in text to the welcome & Thankyou pages it appears for that translation. But if I haven't put in a translated page (as alternative to English (default)) both pages are blank.

This doesn't appear to be the intent of the translation module, since all other questions/headers default to english if no translation is there.

Have I missed a setting? I'm trying this on a dummy site running 2.05+ 140212

Regards, Lloyd.
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.135 secondes
Donation Image