Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Runtime session cookie and problem with Conditional questions not showing

Runtime session cookie and problem with Conditional questions not showing il y a 1 an 4 mois #96923

  • joss
  • Portrait de joss
  • Hors ligne
  • Fresh Lemon
  • Messages : 16
  • Karma: 0
In my demo survey I have a lot of conditional questions where you select an answer and sub-questions occur.

When you run the survey for the first time in a browser everything is wonderful. If you refresh or visit the survey later the next days all conditional questions are not shown, so the survey is wrong.

While searching for the solution, I found out that when I erase the runtime session cookie from the browser, everything works fine!

What exactly is this cookie? "ls55732999468247977246-runtime-28836"
and how can I disable it from loading?

Thanks
L'administrateur a désactivé l'accès en écriture pour le public.

Runtime session cookie and problem with Conditional questions not showing il y a 1 an 4 mois #96944

  • joss
  • Portrait de joss
  • Hors ligne
  • Fresh Lemon
  • Messages : 16
  • Karma: 0
After a lot of beta testing I came to the conclusion that if I erase the creation of the cookie from index.php the problem is not solved. But if I erase it after the creation everything is ok.

It occurs in both Yes or No options at General Settings -> Set cookie to prevent repeated participation, which I think is the start of the problem.

Now MAYBE THE SOLUTION:
When I click "Exit and clear survey" and start again everything works. So trying to go directly to the url h++p://survey/index.php?sid=28836&newtest=Y seems to solve the problem.
L'administrateur a désactivé l'accès en écriture pour le public.

Runtime session cookie and problem with Conditional questions not showing il y a 1 an 4 mois #96952

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 6435
  • Remerciements reçus 840
  • Karma: 249
Hello,
When you run the survey for the first time in a browser everything is wonderful. If you refresh or visit the survey later the next days all conditional questions are not shown, so the survey is wrong.
The old answer of the survey is still here ?

If yes : can you provide a step by step instruction, and a lss file on the bug tracker ?
www.limesurvey.org/community-services/bug-tracker

Denis
L'administrateur a désactivé l'accès en écriture pour le public.

Runtime session cookie and problem with Conditional questions not showing il y a 1 an 4 mois #97061

  • joss
  • Portrait de joss
  • Hors ligne
  • Fresh Lemon
  • Messages : 16
  • Karma: 0
No, the previous answers are not shown
Any idea why this is happening?

Thanks
L'administrateur a désactivé l'accès en écriture pour le public.

Runtime session cookie and problem with Conditional questions not showing il y a 8 mois 1 semaine #104834

  • joss
  • Portrait de joss
  • Hors ligne
  • Fresh Lemon
  • Messages : 16
  • Karma: 0
Found the answer, I had

"Set cookie to prevent repeated participation?" to YES

when I changed to NO the problem stopped
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.131 secondes
Donation Image