Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : token attribute mixed-up

token attribute mixed-up il y a 1 an 2 mois #95977

  • ricardo
  • Portrait de ricardo
  • Hors ligne
  • Expert Lime
  • Messages : 110
  • Remerciements reçus 1
  • Karma: 0
I'm using Version 2.00+ Build 130428

I set up a token list and added a new field attribute_1. The new field was "January 2013" or "August 2012"

I set up an invitation like this:

invitationemail.PNG


However, some people have emailed to me saying that date is not correct. For example, the date for this person is August 2013,

tokenlist_2013-05-14.PNG


but his email shows January 2013.

invitationtruncated.PNG




Other people simply did not get the date:


invitationnodate.PNG


Has anybody else had the same problem?
Dernière édition: il y a 1 an 2 mois par ricardo. Raison: wrong pic
L'administrateur a désactivé l'accès en écriture pour le public.

token attribute mixed-up il y a 10 mois 3 semaines #99380

  • papacico
  • Portrait de papacico
  • Hors ligne
  • Junior Lime
  • Messages : 20
  • Karma: 0
hello Ricardo,

yes i have the same problem the {token:attribute_1} is not returning the value from the token table,

did you already solved this problem? Could you please share the solution?

Thank you bye
L'administrateur a désactivé l'accès en écriture pour le public.

token attribute mixed-up il y a 10 mois 3 semaines #99400

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 6205
  • Remerciements reçus 788
  • Karma: 238
If this happen with last version too, please report the bug.

But i think i see a fix for that some week ago.

Denis
L'administrateur a désactivé l'accès en écriture pour le public.

token attribute mixed-up il y a 10 mois 3 semaines #99441

  • FHemmes
  • Portrait de FHemmes
  • Hors ligne
  • Fresh Lemon
  • Messages : 10
  • Remerciements reçus 1
  • Karma: 0
Hello ricardo, papacico,

I had the same problem some time ago. The email invitations would sometimes load the right tokens, sometimes the wrong ones, and sometimes none at all.

What made the difference for me was using the field replacement tags without the word 'TOKEN' in them. So use {ATTRIBUTE_1} instead of {TOKEN:ATTRIBUTE_1}. Include 'TOKEN' only in the field replacement tags you build into the survey itself.
This solved the problem for me. You can find my thread on this problem here: www.limesurvey.org/en/forum/design-issue...butes-in-invitations

There is also a page in the manual related to replacement field tags that has information on this here: manual.limesurvey.org/Tokens#Emailing

I hope this solves your problem.

Best,
FH
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: papacico

token attribute mixed-up il y a 10 mois 3 semaines #99457

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 6205
  • Remerciements reçus 788
  • Karma: 238
DenisChenu écrit:
If this happen with last version too, please report the bug.
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: papacico

token attribute mixed-up il y a 10 mois 3 semaines #99502

  • papacico
  • Portrait de papacico
  • Hors ligne
  • Junior Lime
  • Messages : 20
  • Karma: 0
thank you Fhemmes and Denis the issue is solved using {ATTRIBUTE_1}

kind regards
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.191 secondes
Donation Image