Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Intermittent problems when browsing the admin pages

Intermittent problems when browsing the admin pages 2 months 3 days ago #111242

  • lenakun
  • lenakun's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
I have installed LimeSurvey on Hostinger via Hostinger's autoinstaller, and I have intermittent issues with the administration pages. When trying to access the authentication page or when I'm working with my survey, making changes and saving and so on, I sometimes get this message:

"Your system folder path does not appear to be set correctly. Please open the following file and correct this: index.php".

This messagge appears randomly on the operations I do. Most of the time it doesn't, and when it does, if I click the page reload browser button I generally get the right page and my changes are saved. Sometimes it gets two or three reloadings to get it right, though.

Also, sometimes it gives a different message: No input file.

Some other times there are messages related to php functions. In all cases all I have to do is reload the page. It's a bit annoying, but what worries me most is that my survey users have the same problem (and sometimes they do - and since they are not computers experts they are likely to just close the browser... and I don't want to lose participants for my Ph.D research!!!).

Does anybody know how to solve this? It appears to me that there is no real problem with the path or the files since 70% of the time it works correctly.

Thanks a lot!!! :) :) :) :)
Last Edit: 2 months 3 days ago by lenakun. Reason: Orthographic errors.
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 2 days ago #111249

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6362
  • Thank you received: 827
  • Karma: 245
lenakun wrote:
I have installed LimeSurvey on Hostinger via Hostinger's autoinstaller,
I think you must contact Hostinger.
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 2 days ago #111255

  • lenakun
  • lenakun's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Thank you for your quick reply!!

Yes, I did that in the first place, but they told me to contact you since it's not their application. They just get your files and put them in the folder...

Is there anything I can do without depending on them?? I'd like to solve this and I don't want to feel like in The Twelve Tasks of Asterix, being sent from one place to another - that's kind of frustrating...

So if there's something I can do I don't know, a test, or modify a file... That'd be most helpful.
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 1 day ago #111277

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6362
  • Thank you received: 827
  • Karma: 245
Hi lenakun,

I never see this problem on this forum, and don't have this problem.

We can not know Hostinger hosting service.

Can you :
1 : Ask to Hostinger the apache error log
2 : Export/print in PDF the phpinfo (you can see it in Gloabl setings)

Denis
The administrator has disabled public write access.
The following user(s) said Thank You: lenakun

Intermittent problems when browsing the admin pages 2 months 1 day ago #111286

  • lenakun
  • lenakun's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Thank you so much for your assistance.

I attatch de PhpInfo PDF. As for the apache error log we'll have to wait until Hostinger replies to me.
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 1 day ago #111291

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2719
  • Thank you received: 331
  • Karma: 121
I would guess it is a problem on there side (those autoinstallers never just take the files and put them in the folder). There is a installation process involved.

However, installing Limesurvey from scratch has become so easy that I think you could give it a try. I would always try to install a clean Limesurvey. Try it, it is quite easy.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 1 day ago #111294

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6362
  • Thank you received: 827
  • Karma: 245
No phpinfo too ;)
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 1 day ago #111301

  • lenakun
  • lenakun's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
That's weird. I've attached the file twice. I clicked the Insert button. It took a while to upload it, I saw in the status bar how the uploaded percentage went up. But no file appears on my post after submitting it!! Here it goes again - I hope it works.

Edit: finally, it worked!



File Attachment:

File Name: InfoPHP.pdf
File Size: 259 KB
Last Edit: 2 months 1 day ago by lenakun. Reason: More info
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 1 day ago #111302

  • lenakun
  • lenakun's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Yeah, I guess I could try and fresh install it but my surveys are ongoing and with a fresh installation I would have to change the survey link - and I can't do that. Nevertheless, I shall try a fresh install on another folder to check if it works, but I'd need to fix the problem on my current surveys folder...
The administrator has disabled public write access.

Intermittent problems when browsing the admin pages 2 months 1 day ago #111304

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2719
  • Thank you received: 331
  • Karma: 121
So the problem only occured after a while? Or did you start various surveys despite the problem?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.112 seconds
Donation Image