Welcome, Guest
Username: Password: Remember me

TOPIC: Update error: This script can only be run on PHP version 5.3.0 or later!

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 2 weeks ago #109709

  • Miguli
  • Miguli's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hey everyone

I recently tried to update my limesurvey version to 2.05. Since then, I can't login anymore, I just see a blank page with this error on it:

This script can only be run on PHP version 5.3.0 or later! Your version: 5.2.17.

I don't understand what this means and what I have to do now.

I would be extremely thankful if someone could help me.

Thanks in advance,
Best regards,
Michael

P.S. Please use simple, step-by-step explanations because I am not much of an expert. :huh:
The administrator has disabled public write access.

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 2 weeks ago #109723

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2684
  • Thank you received: 326
  • Karma: 121
It is quite simple. You need to upgrade your server to PHP 5.3 or higher. Your version is 5.2, thus lower than the requested version.

I assume that you will have to get in touch with your host.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 2 weeks ago #109747

  • Miguli
  • Miguli's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Thanks for your response Holch.

I asked my host (switchplus) how to upgrade and it really seems quite simple.

However, after changing my version to PHP 5.3, I only see a blank page when loading Limesurvey. Not even the error message appears anymore.
Maybe there is some kind of delay until the changes are effective?

Or maybe I chose the wrong edition. There are different PHP editions to upgrade to
1. 5-53Stable
2. 5-53Latest
3. 5-54Stable
4. %-54Latest

And there are also different PHP version to choose from:
1. Extended
2. Light
3. Standard
4. Fast

Of course I tried different combinations of PHP versions and editions. But no combinations worked. I always just see the blank screen when trying to load the login page.

Any ideas?
The administrator has disabled public write access.

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 2 weeks ago #109754

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2684
  • Thank you received: 326
  • Karma: 121
Generally the blank screen was problem of not having PHP 5.3. I assume that you chose the stable releases. So this should not be a problem.

Sometimes it helps to empty the cache.

And please also have a search for "blank page", "white page" in the forum. I remember quite a few solutions to this problem.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 2 weeks ago #109755

  • Miguli
  • Miguli's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Emptying the chache didn't solve it.

I will try to search for the key words in the forum, thanks.

By now, I am wondering if it would'nt be easier just to downgrade my limesurvey again. I was visiting the "old versions" page. But I couldn't find out which was the second last version. Could you help me here?
The administrator has disabled public write access.

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 1 week ago #109851

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6338
  • Thank you received: 819
  • Karma: 243
Hi,

Can you go to application/config/config.php and set debug to 2 .

Denis
The administrator has disabled public write access.

Update error: This script can only be run on PHP version 5.3.0 or later! 3 months 1 week ago #109929

  • Miguli
  • Miguli's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi Denis

Sorry for the basic question, but where do I have to go to applications etc.?

Do you mean in Limesurvey? I cant login to Limesurvey.

Thanks for your help
Michael
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.113 seconds
Donation Image