Welcome, Guest
Username: Password: Remember me

TOPIC: Copy template doesn't work/can't import templates

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108076

  • dirkse
  • dirkse's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Hi all,

I am new to Limesurvey and installed it this afternoon using a script from my hosting provider to test it out. When I try to copy a template so that I can edit it, is seems to lose references to all of the CSS files. (black text on white with no formatting).
I decided to try exporting the template that I wanted to copy, so that I could rename it and reimport it, but I get a 403 error saying that I don't have permission to do that.

I am logged in as administrator, and there are no software updates available.

If anyone has a suggestion for how to fix this I would be most thankful.

Best,
Anne
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108077

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2950
  • Thank you received: 377
  • Karma: 124
The problem is that the script from your provider obviously did not grant the right permissions to the folders. To upload a template (or to copy it) the "upload" folder needs to have the right permissions.

I would honestly recommend to do a clean install from scratch. It is quite simple. You need to create a database and have the data for it (database user, password, etc.).

The installation process is quite straight forward. The scrips provided by the hosters usually are not very well made and often break the installation. Sad but true. Follow the information about installing LS and I think you'll be fen.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: dirkse

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108078

  • dirkse
  • dirkse's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Hi, thanks for your help. I have the information for the database the script created (and which I've since added my surveys to over the past several hours...) so I want to use that at least. Can you tell me what the permissions should be for the uploads folder, by chance? Even trying 777 (recursively, temporarily!) doesn't resolve the problem.

I manage a lot of installs and prefer a control panel where I can easily determine what is where and what needs to be upgraded. I also don't really want to recreate my surveys, so I hope that there is a way to just figure out what's wrong with the install?

Thanks,
Anne
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108079

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2950
  • Thank you received: 377
  • Karma: 124
With those install scripts it is very hard to say what kind of changes they did, or which they did wrong. So it is quite difficult to help. Limesurvey has it's own update/upgrade process included, which works quite well and requires about 3 clicks.

I can understand that you don't want to recreate your surveys, but you do not necessarily have to. You can export them and later import them to the new installation.

In the install instructions is a description about the permissions for certain folders:
manual.limesurvey.org/Installation#Set_Directory_permissions

So check if this solves the problem.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108091

  • dirkse
  • dirkse's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Thanks, but I did the complete manual installation, new directory, new database, new database users, and the same exact problem occurs.

I have tried in both cases changing the directory permissions as listed in the install guide, it does not help.

I'm in the same place I was last night, it is clearly not the fault of the auto-installer.

I'd appreciate any other suggestions, the survey options are great, but the install has been a nightmare.

Thanks,
Anne
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108092

  • dirkse
  • dirkse's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
here is what I am seeing
Attachments:
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108095

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2950
  • Thank you received: 377
  • Karma: 124
Well, there is obviously something wrong with the file and folder permissions on your server.

How do you change the file permissions? For which folders?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 3 weeks ago #108096

  • dirkse
  • dirkse's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Per the instructions, I changed

/limesurvey/tmp
/limesurvey/upload
/limesurvey/application/config

They were 755 initially (same problem), and I changed them recursively to 777 (still same problem). I've changed them using the 'change permissions' (recursive to files and directories) in filezilla.

As you can see from the attachments I added, it is copying the template, and I've checked to see that files are written to the upload/templates directory, but no styles are applied and I still can't import something I've exported.

Both instances (host installed and hand installed) are behaving identically.
The administrator has disabled public write access.

Copy template doesn't work/can't import templates 6 months 2 weeks ago #108157

  • ithink
  • ithink's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
dirkse, I just installed LimeSurvey 2.05 and had the same issue. Also couldn't create questions (though we could create question groups). If you're having both those problems as I am, try version 2.0. That one works for me. :)
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.126 seconds
Donation Image