Welcome, Guest
Username: Password: Remember me

TOPIC: Expression manager always shows syntax errors

Expression manager always shows syntax errors 7 months 1 week ago #106421

  • terminus
  • terminus's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
I am running Limesurvey 2.00+ Build 131206, and I want to add simple conditions like "show question 5 if question 4 was answered yes". Even such simple conditions are failing, and the questions are never shown. See the attachment, which indicates syntax errors with the expression ((4.NAOK"Y")). When I edit the question it appears as ((273243X1X4.NAOK "Y")).

The errors indicated are "Expected expressions separated by commas" and "Extra token found after expressions". It seems that the problem is that the == operator is missing, and has been replaced by spaces. But note that I didn't compose the expression manually, I just used added the condition using the web interface. So is this a bug (perhaps one fixed since 131206)?
Attachments:
Last Edit: 7 months 1 week ago by terminus.
The administrator has disabled public write access.

Expression manager always shows syntax errors 7 months 1 week ago #106425

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6471
  • Thank you received: 854
  • Karma: 254
Did you try to remove the condition and add it again ?

1st time i see this.
The administrator has disabled public write access.

Expression manager always shows syntax errors 7 months 1 week ago #106426

  • terminus
  • terminus's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Yes I tried that. The only workaround that worked was adding the condition, then editing the question to copy the erroneous generated expression (eg. 273243X1X4.NAOK "Y"), then deleting the condition, then adding a manually-edited version of the expression (eg. 273243X1X4.NAOK=="Y"). Works, but is annoying and time-consuming.
The administrator has disabled public write access.

Expression manager always shows syntax errors 7 months 1 week ago #106427

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
What is your question code?
---
Menno Dekker
The administrator has disabled public write access.

Expression manager always shows syntax errors 7 months 1 week ago #106428

  • terminus
  • terminus's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Just sequential numbers, like "1".
The administrator has disabled public write access.

Expression manager always shows syntax errors 7 months 1 week ago #106429

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
That is not supported. If you change it to q1 (so prefix with a letter) all should work fine.
---
Menno Dekker
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.112 seconds
Donation Image