Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Uses left = 0

Uses left = 0 4 months 2 weeks ago #106003

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
Hello,

We are doing interviews on the phone with Limesurvey and created new tokens yesterday, a batch of 20.000 tokens. When creating them i set uses left = 5. But when agents are calling they encounter tokens that suddenly have 0 uses left. What could cause this?
The administrator has disabled public write access.

Uses left = 0 4 months 2 weeks ago #106007

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
Well, there could be many reasons (in LS or outside).

What software are you using for you CATI operations? How is a token assigned to an operator?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Uses left = 0 4 months 2 weeks ago #106049

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
We are using ViCidial which allows an agent to click a button and this opens the URL to vicidial by adding the token as a variable. I checked but these were leads which had not been called before so how could the tokens have been accesses before (assuming this is the case)?
The administrator has disabled public write access.

Uses left = 0 4 months 2 weeks ago #106050

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
OK, I had asked because a wrong implementation of the CATI portion can quickly finish your uses left, if you have a few people in your call center. I am not sure when the uses left ist set to "zero", I think only once the questionnaire was finished. So it also can't be that they just opened the link quickly and closed it again.

I am not sure what the problem could be. Did you check the token table that you uploaded, that they are really all with the same uses left? I am just trying to rule out those things.

Did this happen only in this one case or is this reproducable?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Uses left = 0 4 months 1 week ago #106151

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
I create dummy tokens each time via the limesurvey interface. I don't upload tokens. We did a query with navicat and changed all the tokens that had <5 uses back to 5. This is not the first time this has happened so i'm pretty sure it will happen again. I'll check the tokens immediately after i generate them next time. I also thought that maybe the agents were opening the surveys and closing them again but it turned out these were leads that were never called before but even if they were the uses left field should only be deducted when the last question in the survey is answered right?
The administrator has disabled public write access.

Uses left = 0 4 months 1 week ago #106157

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
dspaan wrote:
.... when the last question in the survey is answered right?
Use left is decremented only when user click on submit.

BUt maybe there are a bug in "admin update answer/create answer" in manual.limesurvey.org/Data_entry ?

Denis
The administrator has disabled public write access.

Uses left = 0 4 months 1 week ago #106169

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
We don't use manual data entry.
The administrator has disabled public write access.

Uses left = 0 4 months 1 week ago #106179

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
dspaan wrote:
We don't use manual data entry.
Something external ? Somewhere else ?

No idea here.

PS: why not use
- Allow multiple responses or update responses with one token? YES
- Enable token-based response persistence : NO

Then your token have an 'infinite' submit system
Last Edit: 4 months 1 week ago by DenisChenu.
The administrator has disabled public write access.

Uses left = 0 2 months 2 weeks ago #108377

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
Hi Denis,

I changed these settings:

Allow editing responses after completion? Yes
Enable token-based response persistence No

But then we get this error:
The token you provided doesn't match the one in your session.
Please wait to begin with a new session.

The agent has to refresh everytime they get the survey script. This doesn't work because it is running in an iframe and as soon as the agent gets the respondent on the phone he should be able to read the survey text. Is there any way to get rid of this session problem?

Also i could not find the setting 'Allow multiple responses or update responses with one token? YES'.
The administrator has disabled public write access.

Uses left = 0 2 months 2 weeks ago #108382

  • Ben_V
  • Ben_V's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 1061
  • Thank you received: 234
  • Karma: 74
tk.gif
Benoît

goo.gl/Bw5iM => Recherche GG dans le forum français (remplacer "exemple" dans la barre de recherche)
goo.gl/WX8PH => GG search for english forum (Replace "example" in the search bar)
goo.gl/IxiGu => Búsqueda en el foro en español (Cambiar "ejemplo" en la barra de...
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.145 seconds
Donation Image