Welcome, Guest
Username: Password: Remember me

TOPIC: htaccess problem?

htaccess problem? 5 months 5 days ago #105264

  • rom
  • rom's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Thank you received: 1
  • Karma: 0
Hi,

we just upgraded from 1.93 to 2.05+. After uploading the new limesurvey files, I was not able to browse to the /admin/ folder using IE 10 to run the database upgrade, the Webserver reported a 500 ERROR. My current Webhoster is named "Domainfactory"... just mentioning it because it may be specific to them.

I fixed this problem by adding the following line to the .htaccess file, right below "RewriteEngine on"
RewriteBase /

Maybe this fix should be considered for future limesurvey builds?
The administrator has disabled public write access.

htaccess problem? 5 months 3 days ago #105347

  • rom
  • rom's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Thank you received: 1
  • Karma: 0
going to report this one as a bug to bugs.limesurvey.org, as no one replied here
The administrator has disabled public write access.

htaccess problem? 1 month 3 weeks ago #109441

If the URL is example.com/limesurvey

We need to specify this in htaccess

RewriteBase /limesurvey/

Seriously...can we have that in the manual???
Last Edit: 1 month 3 weeks ago by DenisChenu.
The administrator has disabled public write access.

htaccess problem? 1 month 3 weeks ago #109450

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
No such problems here, ever.

Whereever I put my installation on the server, no matter which folder, subdomain, etc., I never had to change anything in .htaccess. Maybe a very specific server configuration? For me, on about 5 different hosts this problem never appeared.
Seriously...can we have that in the manual???

The manual is a wiki and everyone can contribute. So if you feel that this is something that needs to be added, feel free to help. Seriously. ;-)
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Last Edit: 1 month 3 weeks ago by holch.
The administrator has disabled public write access.
The following user(s) said Thank You: DenisChenu

htaccess problem? 1 month 3 weeks ago #109502

  • rom
  • rom's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Thank you received: 1
  • Karma: 0
Related Mantis Ticket: bugs.limesurvey.org/view.php?id=8745
The administrator has disabled public write access.

htaccess problem? 1 month 3 weeks ago #109546

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
The RewriteBase is allways a problem in all system, we can't set it by default, because a lot of installtion don't need it (and broke if is set to a bad value).

Denis
The administrator has disabled public write access.

htaccess problem? 1 month 1 week ago #110018

In my case, this problem only occurs in the server that we have it in Virtual Host in a sub-sub directory.

Adding the RewriteBase like this solved my problem.

RewriteBase /limesurvey/


Thank you all.
The administrator has disabled public write access.

htaccess problem? 1 month 1 week ago #110026

hello new here
In the documentation about EM it is mentioned that the assignment operator (=) can be used to set the value of objects that do not accept a default value. Put where should I put this statement? I could put {a=1} on for instance a (hidden?) text display, but I noticed this does not work correctly (the value is only shown after a refresh). What is the best place to put a assignment?
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.166 seconds
Donation Image