Welcome, Guest
Username: Password: Remember me

TOPIC: Sudden loss of admin rights

Sudden loss of admin rights 5 months 3 weeks ago #101061

Hi Everyone,

I've had my own instance of LS (Version 2.00+ Build 121101) that has been working fine for some time. I installed it and am the super admin (don't feel "super" now though...).

I went in this morning and saw that my admin controls now do not allow me the permission set to create new users etc.

Does anyone know what might have happened AND can anyone tell me how to re-establish myself in my own domain (hopefully without shutting down surveys that are running and re-installing LS) as the super admin?

Thank you in advance for any help or advice.

-George
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 3 weeks ago #101066

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2442
  • Thank you received: 254
  • Karma: 94
That sounds pretty weird and I haven't heard of such a behavior in the forum yet.

Limesurvey shouldn't change rights simply like that. That might sound stupid, but things like that happen: did you log in as the super user or maybe as some other user?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101093

Hi Holch,

I logged in as usual (the one ID I have), and I see the difference in the admin interface, most especially that I no longer have the rights to create other users.

Most likely, I did something while I was cleaning out users who no longer use my instance.

The question remains, is there a document in the LS admin files where I can make a change to correct this? ie, to reset myself to super admin?

Thanks for your reply!

Hopefully, you or someone can direct me to fix this.

-George
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101096

Hi Everyone,

This is really strange, and I hope someone in here will read this and help.

I just looked at my user settings using PHPmyAdmin and verified that my identity does have super user rights. But, the entire interface to create new users is gone - I can only access myself, and there is no where to create new users. Not only that, but I cannot even change my own password - the interface is gone.

Any ideas what's going on?

-George
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101097

georgebradford wrote:
Hi Everyone,

This is really strange, and I hope someone in here will read this and help.

I just looked at my user settings using PHPmyAdmin and verified that my identity does have super user rights. But, the entire interface to create new users is gone - I can only access myself, and there is no where to create new users. Not only that, but I cannot even change my own password - the interface is gone.

Any ideas what's going on?

-George

I am attaching a screen capture to show you what I see when I first log in - as a super user.

-George


hf0f850a.png
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101098

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 719
  • Thank you received: 91
  • Karma: 83
Never seen that. If you have superadmin permissions you should see everything. Did you clear cache and everything after update? Did you try a different browser?
Support us, too. Donate to the LimeSurvey project and help keep us going!
Last Edit: 5 months 2 weeks ago by c_schmitz.
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101122

Hi c_schmitz,

Yes, I tried IE (latest version - just updated to windows 8.1 pro), Firefox, and Chrome. Cache and everything cleared. The image above is all I can see, and as I mentioned, I cannot even get to the window to change my password.

The last thing I did before this happened is I removed a user who no longer needed to access my LS instance. But when I look at the table in PHPmyAdmin, I see that user still in the table, along with me and one other individual. I am the only person in the table with a 1 in the super user field.

Any ideas?

-George
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101123

georgebradford wrote:
Hi c_schmitz,

Yes, I tried IE (latest version - just updated to windows 8.1 pro), Firefox, and Chrome. Cache and everything cleared. The image above is all I can see, and as I mentioned, I cannot even get to the window to change my password.

The last thing I did before this happened is I removed a user who no longer needed to access my LS instance. But when I look at the table in PHPmyAdmin, I see that user still in the table, along with me and one other individual. I am the only person in the table with a 1 in the super user field.

Any ideas?

-George

Just to be clear, see the image below of what is missing in my instance (when I captured this image, I logged into another instance where I am a regular user - ie, the university where I work)...

-George
Attachments:
The administrator has disabled public write access.

Sudden loss of admin rights 5 months 2 weeks ago #101141

Instead of it being a loss of super admin rights, I think that what's happened is that I have lost the navigation icons to those web pages where you manage users, passwords, etc. Click on the last image I uploaded to see what I'm referring to.

So the question is, how do I get the navigation icons back?

Thank you for any help on this!

-George
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.141 seconds
Donation Image