Welcome, Guest
Username: Password: Remember me

TOPIC: Installation on webserver doesn't work

Installation on webserver doesn't work 7 months 4 weeks ago #99186

  • mav
  • mav's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hello,

I installed limesurvey on the localhost, which works.
I tried to install Limesurvey on a webserver, but it doesn't work.
The files have been uploaded in binary mode.
The server accepts mysql and php5.
I tried to open several php-scripts (Index.php, admin.php, config.php) in the browser, but every time I get the 404-Error "the page doesn't exist".

What am I doing wrong?
The administrator has disabled public write access.

Installation on webserver doesn't work 7 months 4 weeks ago #99189

  • jamesxin
  • jamesxin's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I have the same issue.I installed on ipage.com and it worked with 2.0+ but now it does not work. When I put the URL to visit the admin page. It gave me error message: 403.Page not found. I found that the URL became www.xxx.com/limesurvey/index.php/admin from www.xxx.com/limesurvey/admin/index.php.

But if you install the <1.9 version it worked and it took you to the correct URL. The technician said there was something related to router file. But I don't know how to do it.
The administrator has disabled public write access.

Installation on webserver doesn't work 7 months 4 weeks ago #99191

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2444
  • Thank you received: 254
  • Karma: 94
Do you have mod_rewrite activated?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Installation on webserver doesn't work 7 months 4 weeks ago #99192

  • jamesxin
  • jamesxin's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
How can I do that?Thanks!
The administrator has disabled public write access.

Installation on webserver doesn't work 7 months 4 weeks ago #99209

  • mav
  • mav's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I tried to open it with the Basic-URL
***.bplaced.net. The Index-side appears. After clicking on the Limesurvey-folder, the following message comes up:

Fatal error: Class 'Yii' not found in /users/xxx/www/Limesurvey/application/config/config.php on line 578

Where can I adjust the Class 'Yii' ?
The administrator has disabled public write access.

Installation on webserver doesn't work 7 months 4 weeks ago #99215

  • jamesxin
  • jamesxin's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
My htaccess is as the following. Does this mean that rewrite engine is on?

<IfModule mod_rewrite.c>
RewriteEngine on

# if a directory or a file exists, use it directly
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

# otherwise forward it to index.php
RewriteRule . index.php
</IfModule>
# General setting to properly handle LimeSurvey paths
# AcceptPathInfo on
# session.save_path /limesurvey/var/php_sessions


Thanks!
The administrator has disabled public write access.

Installation on webserver doesn't work 7 months 4 weeks ago #99221

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2444
  • Thank you received: 254
  • Karma: 94
seeems like you didn't upload all files completely. This can happen sometimes, depending on your connection, the FTP program, etc. etc.

Compare if all files are uploaded and if the size is the same on the server.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: mav

Installation on webserver doesn't work 7 months 4 weeks ago #99242

  • mav
  • mav's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
thanks a lot
I installed limesurvey completely again.
Afterwards I tipped in the URL and the installation-window appeared.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.120 seconds
Donation Image