Welcome, Guest
Username: Password: Remember me

TOPIC: Install Error 2.0

Install Error 2.0 1 year 1 month ago #98096

  • mark3397
  • mark3397's Avatar
My brand new installation is failing at:

$config = Yii::app()->baseUrl . '/'; // The public website location (url) of the public survey script

in application/config/config-defaults when it calls Yii::app()->baseUrl

I've tried:
Yii::app()->request->baseUrl
and
Yii::app()->request->getBaseUrl(true)
as well.
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98100

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
What error do you get? How did you trace it down to the baseurl?
---
Menno Dekker
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98106

  • mark3397
  • mark3397's Avatar
It just stops processing.

I traced it down by following the workflow and putting:
echo "I am here<br>";
starting from the index.php and got all the way to application/config/config-defaults.php to that line.

It won't go past that line.
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98107

  • mark3397
  • mark3397's Avatar
What are the system requirements for the mini-Yii framework?

Are they all supposed to be included in the 2.0 download?
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98120

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6276
  • Thank you received: 801
  • Karma: 241
ANd, why not use directly:
$config['publicurl'] = "http://myrealurl.example.org";

?
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98136

  • mark3397
  • mark3397's Avatar
Where would that go?
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98137

  • mark3397
  • mark3397's Avatar
I only ask, because I have this in my config.php:

'config'=>array(
// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
// on your webspace.
// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
'debug'=>2,
'debugsql'=>1, // Set this to 1 to enanble sql logging, only active when debug = 2
'publicurl'=>'http://realserver/limesuvey/',
'urlFormat'=>'get'
Last Edit: 1 year 1 month ago by mark3397.
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98138

  • mark3397
  • mark3397's Avatar
'publicurl'=>'h ttp://realserver/limesuvey/',

Space added for the website formats it if it says http
Last Edit: 1 year 1 month ago by mark3397.
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98139

  • mark3397
  • mark3397's Avatar
Ok, that got me past that part, but I still have a blank screen.

Can someone give me some pointers on logs or debugging this thing as that nothing is spit out. I've read the Install FAQ a few dozen times and checked everything multiple times. What info could I provide that might help my situation?
The administrator has disabled public write access.

Install Error 2.0 1 year 1 month ago #98142

  • mark3397
  • mark3397's Avatar
I just downloaded V191, build 120302 and had it up and running in 5 minutes on the same host. Still no idea what is going on with V2.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.204 seconds
Donation Image