Welcome, Guest
Username: Password: Remember me

TOPIC: First Installation -

First Installation - 1 year 3 months ago #95210

  • ylafont
  • ylafont's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Hope someone can point me in the right direction, I am new to Apache and I have been trying to install limesurvey (without success!) to test. I have followed the instruction on manual.limesurvey.org/Installation , and I know I am missing something that is tken for granted.

I have downloaded the latest version of LimeSurvey, Extracted it, moved it over to the Apache root Server Directory and Modified the rights of the files. All dependencies are aslo in order

When I go to launch the installer - I get

Not Found
The requested URL /limesurvey/admin was not found on this server.

What apache configuration need to be taken care of?

Thanks for the assistance.
The administrator has disabled public write access.

First Installation - 1 year 3 months ago #95211

  • kobaltz
  • kobaltz's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 4
  • Karma: 1
Is this Apache site hosting other websites or just the limesurvey? Can you post your config file (normally httpd.conf).
The administrator has disabled public write access.

First Installation - 1 year 3 months ago #95213

  • kobaltz
  • kobaltz's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 4
  • Karma: 1
You could try to insert this at the end of your configuration file. Change
path to /limesurvey/htdocs
to the path to the htdocs location of your limesurvey installation.
Alias /limesurvey/ "path to /limesurvey/htdocs/"
Alias /limesurvey "path to /limesurvey/htdocs"
 
<Directory "path to /limesurvey/htdocs">
    Options +MultiViews
    AllowOverride All
    <IfVersion < 2.3 >
    Order allow,deny
    Allow from all
    </IfVersion>
    <IfVersion >= 2.3>
    Require all granted
    </IfVersion>
</Directory>
Last Edit: 1 year 3 months ago by kobaltz. Reason: path
The administrator has disabled public write access.

First Installation - 1 year 3 months ago #95214

  • ylafont
  • ylafont's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0

File Attachment:

File Name: httpd.conf.txt
File Size: 18 KB


Thank you for responding kobaltz, I can use the assistance.

I am attaching httpd.conf, for review.

To make things easier, I took the Bitnami Drupal VM machine - since my ultimate goal is to integrate them together.

The machine has several applications, however I believe the answer to Q1 question is no.

also, the limesurvey tar file does not include a htdocs folder. I am assuming that this is location of where the tar file should be extracted to. (Correct?)

current /opt/bitnami/apache2 is the server root and /opt/bitnami/apps is where all of the web applications are install in there own seperate folder. so i have

opt/bitnami/apps/drupal
opt/bitnami/apps/limesurvey
opt/bitnami/apps/phpmyadmin
opt/bitnam1/apps/wordpress

the tar file was extract to /opt/bitnami/apps/limesurvey/htdocs
Last Edit: 1 year 3 months ago by ylafont.
The administrator has disabled public write access.

First Installation - 1 year 3 months ago #95215

  • ylafont
  • ylafont's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
kobaltz - base on what you gave me i was able to piece it together. I am sure these instructions are somewhere, however i could not find any reference to them.

1) Modified the the appache httpd.conf and inserted the following line:

Include "/opt/bitnami/apps/limesurvey/conf/limesurvey.conf"

2) Create the limesurvey.conf file /opt/bitnami/apps/limesurvey/conf with the followin

Alias /limesurvey/ "/opt/bitnami/apps/limesurvey/htdocs/"
Alias /limesurvey "/opt/bitnami/apps/limesurvey/htdocs"

<Directory "/opt/bitnami/apps/limesurvey/htdocs">
Options +MultiViews
AllowOverride all
<IfVersion < 2.3 >
Order allow,deny
Allow from all
</IfVersion>
<IfVersion >= 2.3>
Require all granted
</IfVersion>
</Directory>

# Uncomment the following lines to see your application in the root
# of your URL. This is not compatible with more than one application.
#RewriteEngine On
#RewriteRule ^/$ /limesurvey/ [PT]

Include "/opt/bitnami/apps/limesurvey/conf/htaccess.conf"

I also took htaccess.conf from one of the other applications.

after i rebooted the installation went smoothly.
The administrator has disabled public write access.

First Installation - 1 year 3 months ago #95227

  • kobaltz
  • kobaltz's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 4
  • Karma: 1
Glad to hear!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.219 seconds
Donation Image