Welcome, Guest
Username: Password: Remember me

TOPIC: Internal Server Error: The table "{{answers}}" for active record class "Answers"

Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 8 months ago #92324

  • kris
  • kris's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hello

After upgrading to LimeSurvey 2.0 (build130206), I had problems with surveys.
When opening one of the surveys I got this.

Internal Server Error: The table "{{answers}}" for active record class "Answers"

I've have looked what the problem got be, but I can't figure it out.
It only happened on the server (PHP 5.1.6) but on a local server (Xampp) it all works (with php 5.2.0) fine.

For now I've downgraded it again to 1.92 but I would like to use 2.0.
I will run some test on the local server to find the problem.

Did someone got the same problem?
Can it be fixed??


If I found the solution, I will let you know.

Update

I have found that running in version php 5.1.6 and php 5.2.0 local xampp, the problems occurs.

Another survey when loading it shows the following error

Internal Server Error

CDbCommand failed to execute the SQL statement: SQLSTATE[HY000]: General error: 2014 Cannot execute queries while other unbuffered queries are active. Consider using PDOStatement::fetchAll(). Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute.


No errors for now occurs when using php 5.3.5 local xampp
Last Edit: 1 year 8 months ago by kris.
The administrator has disabled public write access.

Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 7 months ago #93170

  • kris
  • kris's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Can this be fixed?
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.086 seconds
Donation Image