Welcome, Guest
Username: Password: Remember me

TOPIC: Limesurvey 2 and 1and1 hosting

Limesurvey 2 and 1and1 hosting 1 year 2 months ago #92001

  • xamarshahx
  • xamarshahx's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
I was upgrading to the newest version of Limesurvey from 1.92 and it looks like the ComfortUpdate screwed something up. I was able to restore it, but I started a new installation in another folder. I uploaded all of the files to 1and1 and loaded the Installer.
It keeps stalling on the database settings. It keeps telling me: "Connection with database failed. Please check database location, user name and password and try again."

I tried even creating an additional MySQL database and get the same error. I also tried re-uploading all the files and I get this same error. Instead of an IP address or localhost, 1and1 uses this as the database server: localhost:/tmp/mysql5.sock
It has not been an issue on older installations.

Anyone have any solutions? Thanks.
The administrator has disabled public write access.

Re: Limesurvey 2 and 1and1 hosting 1 year 2 months ago #92004

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2447
  • Thank you received: 254
  • Karma: 94
Did you check whether your server offers PDO? LS2 needs pdo, while LS 1.9x didn't.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Limesurvey 2 and 1and1 hosting 1 year 2 months ago #92818

  • jme
  • jme's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
I was having the same issue and after an hour of hacking around in the code I have found what you need to do.

Open application/controllers/InstallerController.php and around line 1108 in the _getDsn function you will find this:
$dsn = "mysql:host={$sDatabaseLocation};port={$sDatabasePort};dbname={$sDatabaseName};"

Change to this
$dsn = "mysql:unix_socket={$sDatabaseLocation};port={$sDatabasePort};dbname={$sDatabaseName};";

And the install will run as normal but in the host box instead of localhost put /tmp/mysql5.sock
The administrator has disabled public write access.
The following user(s) said Thank You: Ben_V

Limesurvey 2 and 1and1 hosting 1 year 2 months ago #92823

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2447
  • Thank you received: 254
  • Karma: 94
Hi jme!

Sounds good. Maybe you can provide this as a patch to the developers? Or if it can't be taken into the core, you could add this description to the installation guide.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.205 seconds
Donation Image