Welcome, Guest
Username: Password: Remember me

TOPIC: Adding a language - Property "CDbCriteria.0" is not defined.

Adding a language - Property "CDbCriteria.0" is not defined. 1 year 7 months ago #91758

Hi hello!

I was keen to use the new build because there is a new language on there that I desperately need. However, when I try to add any language to my base English survey I get the error message
Property "CDbCriteria.0" is not defined.
. What's that about, and what can I do?
The administrator has disabled public write access.

Re: Adding a language - Property "CDbCriteria.0" is not defined. 1 year 7 months ago #91762

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
The bug will be fixed in the next version. If you are in a hurry and want to edit the file yourself, check out this commit:
github.com/LimeSurvey/LimeSurvey/commit/...5c4c377351c61b844272
---
Menno Dekker
The administrator has disabled public write access.
The following user(s) said Thank You: GalloiseBlonde

Re: Adding a language - Property "CDbCriteria.0" is not defined. 1 year 7 months ago #91776

Thank you mdekker, I may well give that a go. Love the UI on the latest build BTW.
The administrator has disabled public write access.

Re: Adding a language - Property "CDbCriteria.0" is not defined. 1 year 7 months ago #91832

Hi - it turns out there is another problem with secondary languages in the new build, which is that template changes and so on are only affecting the primary language. Annoyingly, this means my secondary language is appearing as question by question rather than in pages, and not using the template I redesigned with logos and stuff. Does anyone have any idea what's going on there?

PS: mdekker's alt worked perfectly!
Last Edit: 1 year 7 months ago by GalloiseBlonde.
The administrator has disabled public write access.

Re: Adding a language - Property "CDbCriteria.0" is not defined. 1 year 7 months ago #91833

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
Probably your second language has no settings. Try changing texts for the language, that should fix your problem. If not, I think it will be fixed in the next build since some changes related to this have been done. The next build will probably be released later today (when we find no big issues)
---
Menno Dekker
The administrator has disabled public write access.
The following user(s) said Thank You: GalloiseBlonde

Re: Adding a language - Property "CDbCriteria.0" is not defined. 1 year 7 months ago #91835

I reckon I'll wait for the new build then, if it's coming so soon. Thank you so much: your responses here have been very impressive. I'm glad I chose Limesurvey.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.155 seconds
Donation Image