Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1
  • 2

THEMA: Updated 2.0: Template

Updated 2.0: Template 1 Jahr 7 Monate her #91563

  • vs_arni
  • vs_arnis Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 64
  • Karma: 0
Hi, I use a personalized template, by LS personnel.
I have updated to 2.0 release, and now it appears a "0%" and "100%" on the left-top of the screen for every answer. I don't want it.

But... I try to attach a 16Kb screebshot to let see you, but I am no able!
How can I do?

TIA
Arnaldo
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Updated 2.0: Template 1 Jahr 7 Monate her #91610

  • helper
  • helpers Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 126
  • Dank erhalten: 18
  • Karma: 0
The "0%" and "100%" are probably your progress bar. Try changing this setting to "No" in your survey > Survey properties > General settings > Presentation & navigation.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Updated 2.0: Template 1 Jahr 7 Monate her #91615

  • vs_arni
  • vs_arnis Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 64
  • Karma: 0
Yes, if I set "no" it desappears.
But before the update I always used the "yes" setting and there was a beautiful white progress bar. Now I have two static numbers for all questions, "0%" and "100%".

Arnaldo.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Updated 2.0: Template 1 Jahr 7 Monate her #91638

  • helper
  • helpers Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 126
  • Dank erhalten: 18
  • Karma: 0
You may want to update your CSS with the following:
#progress-pre, #progress-post {display:none;}

This should hide the two values, and how you style your progressbar is up to you :)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Updated 2.0: Template 1 Jahr 7 Monate her #91641

  • vs_arni
  • vs_arnis Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 64
  • Karma: 0
Yes. But I would say that in the passage from 1.9x to 2.0 release, something has gone wrong. In the previous version the progress bar was running well. Not in this one.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Updated 2.0: Template 1 Jahr 5 Monate her #93968

  • Limer2001
  • Limer2001s Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 18
  • Dank erhalten: 2
  • Karma: 0
I have the same problem, the progress bar is broken on all my templates after upgrading 1.92 > 2.00 +

Anyone have an idea how to fix it?
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: vs_arni

Re: Updated 2.0: Template 1 Jahr 3 Monate her #95956

  • de_chris
  • de_chriss Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 15
  • Karma: 0
Anyone a solution for the progressbar?
Same problem here after upgrade. Created bug report.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Updated 2.0: Template 1 Jahr 3 Monate her #95957

  • Limer2001
  • Limer2001s Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 18
  • Dank erhalten: 2
  • Karma: 0
Recently fixed it posted the solution in this topic: www.limesurvey.org/de/forum/installation...-work-in-ls-20#95634




Fixed the progress bar! :)


Fixed it by adding the following code to template.css in my custom template. I took this code from the default template.


/** Progress bar **/
#progress-wrapper .ui-widget-content {
border: 1px solid #999999;
}

#progress-wrapper .ui-widget-header {
background-color: #CCCCCC;
border: 1px solid #999999;
}

.page-odd td.graph {
background-color: #D2F2D3;
}

.ui-progressbar { height:1em; width:8em; text-align: left; overflow: hidden; }
.ui-progressbar .ui-progressbar-value {margin: -1px; height:100%; }


#progress-pre{display:none;} /**hides the "0%" text **/

#progress-post {font-size:10px}
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: de_chris

Re: Updated 2.0: Template 1 Jahr 3 Monate her #95975

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6277
  • Dank erhalten: 802
  • Karma: 241
Look if you have {TEMPLATEJS} in your startpage.pstpl.

It's must be done during update process, but sometimes it fail (and you have this information in the update process).

Denis
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: de_chris

Re: Updated 2.0: Template 1 Jahr 3 Monate her #95993

  • de_chris
  • de_chriss Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 15
  • Karma: 0
Thanks for the fast reply. Although {TEMPLATEJS} is available there is only a div with the id "progressbar" but no classes and no content. Therefore solution by Limer2001 won't work.
To reproduce:
installed a fresh version 2.0+
exported my template in version 192
imported my template to version 2.0+
Letzte Änderung: 1 Jahr 3 Monate her von de_chris.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
  • Seite:
  • 1
  • 2
Moderatoren: ITEd
Ladezeit der Seite: 0.219 Sekunden
Donation Image