Welcome, Guest
Username: Password: Remember me

TOPIC: Internal Server Error: The table "{{answers}}" for active record class "Answers"

Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 10 months ago #91427

  • wesma
  • wesma's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hey there,

I keep getting the error
Internal Server Error
The table "{{answers}}" for active record class "Answers" cannot be found in the database.
when I add a question with type array. A Survey containing only questions without this type will work.

I'm running LimeSurvey Version 2.00+ Build 130116

Had that issue just on one server running Linux, excerpt from phpinfo() below:
Linux umfrage.mydomain.de 2.6.18-308.11.1.el5xen #1 SMP Fri Jun 15 16:19:17 EDT 2012 x86_64
'./configure' '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib64' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--with-mime-magic=/usr/share/file/magic.mime' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--without-odbc' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter'
Apache 2.0 Handler
PHP Version 5.1.6

The error occured on an installation of LS 1.92 updated to 2.00+ and on a fresh installation of LS 2.00+ as well.

Another installation in a VirtualBox running WinXP_32 and the LS 2.00-XAMPP-installation package runs without problems.

Anyone has an idea on that? - Would be great!

Thanks
Matthias
The administrator has disabled public write access.

Re: Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 10 months ago #91472

  • Enki
  • Enki's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I posted about the same issue a week or so ago. Any luck on finding a solution?
The administrator has disabled public write access.

Re: Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 10 months ago #91474

  • wesma
  • wesma's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hey.

Yeah, I've seen that.

You think, it's the same problem? Seems you came there from another error, didn't you?
The administrator has disabled public write access.

Re: Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 10 months ago #91522

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 868
  • Karma: 257
Did you have a table suffix_answers ?

?
The administrator has disabled public write access.

Re: Internal Server Error: The table "{{answers}}" for active record class "Answers" 1 year 10 months ago #91597

  • wesma
  • wesma's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hi!

Yes, that table exists.


I "fixed" my problem by downgrading back to 1.91 now, cause I need a working system immediately, but if someone has a clue about a possible solution let us know.

Thanks a lot!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.360 seconds
Donation Image