Welcome, Guest
Username: Password: Remember me

TOPIC: Regex validation no longer working after updating to Version 2.00+ Build 130110

Regex validation no longer working after updating to Version 2.00+ Build 130110 1 year 9 months ago #91075

  • Sweden
  • Sweden's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 64
  • Thank you received: 1
  • Karma: 2
I have this regex /^(te-i5e9tx2wc43x)$/ in the validation field of a short free text question (hidden with js). I am prefilling this question answer using the survey URL (for access control).

It worked just fine until I updated to Version 2.00+ Build 130110 :( - I have cleared my cache and restarted everything but nothing happens when I click the "Next" button. For some reason it doesn't seem to pass the validation - it works if I remove the regex...

What could be wrong?
The administrator has disabled public write access.

Re: Regex validation no longer working after updating to Version 2.00+ Build 130110 1 year 9 months ago #91076

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 810
  • Thank you received: 115
  • Karma: 93
What was your previous version/build ?
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: Regex validation no longer working after updating to Version 2.00+ Build 130110 1 year 9 months ago #91077

  • Sweden
  • Sweden's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 64
  • Thank you received: 1
  • Karma: 2
I believe it was the previous version - it hasn't been that long since I last updated.
The administrator has disabled public write access.

Re: Regex validation no longer working after updating to Version 2.00+ Build 130110 1 year 9 months ago #91079

  • Sweden
  • Sweden's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 64
  • Thank you received: 1
  • Karma: 2
Is it difficult to downgrade? Or even better, is there a solution to this problem? It would be nice if someone could confirm that there is a real problem with regex validation in version 2.00+ build 130110 so I know it isn't a problem on my side. Thanks.
The administrator has disabled public write access.

Re: Regex validation no longer working after updating to Version 2.00+ Build 130110 1 year 9 months ago #91081

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Hello Sweden,

Can you tell us whet is your version before upgrading ?

Thanks
The administrator has disabled public write access.

Re: Regex validation no longer working after updating to Version 2.00+ Build 130110 1 year 9 months ago #91145

  • Sweden
  • Sweden's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 64
  • Thank you received: 1
  • Karma: 2
Hello DenisChenu,

I am not sure - how do I find that info? As I said before, it hasn't been that long since I last updated so the previous version wasn't really that old. Does anyone else have this problem with regex validation?

Thanks
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.120 seconds
Donation Image