Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: No Input File Specified

No Input File Specified 1 year 3 months ago #90983

  • am91962
  • am91962's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
I'm currently attempting to update from 1.92 to 2.00. I deleted the "limesurvey" folder that contained 1.92 and uploaded 2.00 build 130110. The installer comes up and I get to the part where I input the database login/path/password information. I used the same info that was in the 1.92 config file. I hit enter and it says "everything's updated" (or something similar) and then redirects to a page that is completely blank, except it says "No input file specified." I've seen some other posters who had that problem and followed their solutions (changing the permissions on the limesurvey folder), but have had no luck. I'm installing on GoDaddy, using MySQL 5.0 and PHP 5.0.

Thanks in advance for any help,

Andrew
The administrator has disabled public write access.

Re: No Input File Specified 1 year 2 months ago #91942

  • am91962
  • am91962's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Was my post stupid or deficient in some way? Any ideas or should I just move on?

Thanks,

Andrew
The administrator has disabled public write access.

Re: No Input File Specified 1 year 2 months ago #91945

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2442
  • Thank you received: 254
  • Karma: 94
You don't seem to be the only one: bugs.limesurvey.org/view.php?id=5925

Guess what: it's on Godaddy... which would make me think it is a problem on the GoDaddy server configuration.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: No Input File Specified 1 year 2 months ago #91946

  • am91962
  • am91962's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
I've seen others had have problems with 2.0+ on GoDaddy. I thought maybe someone might have an idea of a work-around. I've been running 1.0+ on my GoDaddy for years with no problems. Can you recommend any good US hosting companies? I have a project I have to start Saturday, so I've gone back to v1.92, but I'd like to take advantage of the new features.

Thanks for your time,

Andrew
The administrator has disabled public write access.

Re: No Input File Specified 1 year 2 months ago #91957

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2442
  • Thank you received: 254
  • Karma: 94
Sorry, no idea about US hosters. GoDaddy is definitely not one (never has been) from what I see.

I am running my own vServer, but also there had to do some upgrades so that 2.0 would run, while 1.9x was running out of the box.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: No Input File Specified 1 year 2 months ago #92339

I found the following answer on

stackoverflow.com/questions/14763580/lim...dy/14772590#14772590

It works! I am upgrading to 2.0 on GoDaddy.

=================

Try editing /application/config/config.php and set the line

'urlFormat' => 'path',
to

'urlFormat' => 'get',
then visit your.domain.com/limesurvey/admin again. The URL format should have slightly changed now but at least it will work.
The administrator has disabled public write access.

No Input File Specified 1 year 1 month ago #92764

I did have the same problem...and I'm using Godaddy!
Below change solved the problem. Not sure of the implications.

Try editing /application/config/config.php and set the line

'urlFormat' => 'path',

to

'urlFormat' => 'get',
The administrator has disabled public write access.

No Input File Specified 1 year 1 month ago #92919

  • am91962
  • am91962's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Thanks for the information. We currently have projects running, so I haven't been able to test it out yet, but thanks for the help. As soon as we have downtime I'll be making the upgrade.
The administrator has disabled public write access.

No Input File Specified 1 year 2 weeks ago #94499

  • am91962
  • am91962's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
This worked perfectly. Thanks again for the help.
The administrator has disabled public write access.

No Input File Specified 1 year 2 weeks ago #94507

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 5838
  • Thank you received: 714
  • Karma: 222
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.177 seconds
Donation Image