Welcome, Guest
Username: Password: Remember me

TOPIC: Comfort Update to 121211

Comfort Update to 121211 1 year 11 months ago #90028

  • quaint
  • quaint's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Thank you received: 1
  • Karma: 0
Hello,

I recently upgraded my LimeSurvey installation to 121211, however I've spotted a couple of glitches with the upgrade.

Firstly, when running the comfortupdate to 121211, the $rooturl problem described here returns - the survey URLs are displayed as IP addresses rather than the domain name specified in config.php.

Secondly, I no longer appear to be able to modify sub-questions. I have read through the document herehowever I don't think that the same issue is at fault.

Just for testing purposes, I did a clean install of 121211 into a new subdirectory on my server, creating a new DB. This solved the modify sub-questions problem - I was able to add, delete and edit just fine. I deleted that install and created another fresh install, this time pointing my existing LimeSurvey database; again the sub-questions worked fine.

In the new fresh installs though, the rooturl problem was still evident; surveys links are being reported by IP address, and this persisted even with the config.php from a known working backup.

For the live install, I copied back from the backup zip created by comfortupdate in the /tmp folder, which restores the expected survey URL issue, however it doesn't appear to fix the subquestions issue.

So my options appear to be:

1) Use a fresh (non-comfortupdate) install of 121211 and find another way of fixing the root url bug

2) Keep the URLs correct, but not be able to add sub-questions.

At the moment, I think I'm going to have to use option 2; if I need to add in a new survey before a bug fix I can create a fresh database install then port over the survey structure to the working-URL version.

Thanks in advance for any help.
The administrator has disabled public write access.

Re: Comfort Update to 121211 1 year 11 months ago #90074

  • quaint
  • quaint's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Thank you received: 1
  • Karma: 0
Now this is particularly odd - I can add and modify sub-questions again.

Haven't touched anything - not a sausage - but for some reason it's behaving as expected.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.101 seconds
Donation Image