Welcome, Guest
Username: Password: Remember me

TOPIC: Blank screen after database upload with XAMPP

Blank screen after database upload with XAMPP 1 year 9 months ago #86404

  • relliott
  • relliott's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
I am running limesurvey 200 121002 on XAMPP. When I try to open

your.domain.com/limesurvey/admin

the page is blank. I read the section about this in the FAQs and have tried to manually update the code in config-defaults.php (the files named config.php as mentioned in the FAQ did not contain $rooturl or $rootdir).

The original file was
$config['rootdir']  =  getcwd(); //dirname(__FILE__); //

I first took out the // changing it to
$config = getcwd(); dirname(__FILE__);

That didn't work, so I tried
$config = getcwd(); /home/admin/public_html/limesurvey;

Because "admin" is my limesurvey username. That didn't work. So I tried using my computer's ID and the path to the limesurvey

$config = getcwd(); /home/this_mac/xampp/htdocs/limesurvey;

But that's not working either. My XAMPP access log shows a 200 status with every request, so I think the problem must be somewhere in LS. My operating system is OSX, in case that helps.

Any help would be much appreciated--as you can probably guess, I'm a newbie. Thank you in advance.
Last Edit: 1 year 9 months ago by relliott.
The administrator has disabled public write access.

Re: Blank screen after database upload with XAMPP 1 year 9 months ago #86477

  • relliott
  • relliott's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
I ended up removing version 200 and installing 192.

It did not seem possible to solve this problem in 200, or at least it wasn't soluble by me. I searched for about a day to find $rooturl as described in the FAQs and Installation Manual in any config file, and then in any file at all. It was not there. I also tried a million combinations of the file name in the closest thing I could find, $config under config-default, just because nothing was working.

Unfortunately, none of these things helped.

After installing 192, the problem was fixed in less than a minute!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.151 seconds
Donation Image