Welcome, Guest
Username: Password: Remember me

TOPIC: LDAP authentication in LS 2.00+

Re: LDAP authentication in LS 2.00+ 1 year 1 day ago #98354

  • atlet
  • atlet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
Yes, plugin is activated.

Paste is here: http://pastebin.com/njTxXMEf

I click on link to activate the "login process". Also, the user exist in db...
The administrator has disabled public write access.

Re: LDAP authentication in LS 2.00+ 1 year 1 day ago #98373

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
To rule out errors on other code, try moving setAuthPlugin outside the if, to line 33 for example. Then you should always reach the newUserSession.

When you enable debug mode in your config.php you can log to the console using traceVar() that can be helpful at times.
---
Menno Dekker
The administrator has disabled public write access.
The following user(s) said Thank You: atlet

Re: LDAP authentication in LS 2.00+ 1 year 1 day ago #98382

  • atlet
  • atlet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
If I put $this->setAuthPlugin(); this outside if statement, I get redirection loop.
The administrator has disabled public write access.

Re: LDAP authentication in LS 2.00+ 1 year 22 hours ago #98388

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
Probably you have trouble detecting if someone is logged in. Try adding some debug statements to see what you have in the beforeLogin method (get, post, as->attributes etc.)
---
Menno Dekker
The administrator has disabled public write access.

Re: LDAP authentication in LS 2.00+ 1 year 21 hours ago #98392

  • atlet
  • atlet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
Now I created simple plugin just for test if I can login: pastebin.com/08ycJBn9

User is admin...

If I did it right, I must be logged in when I go to LimeSurvey url : admin/authentication/sa/login?testlogin=1 but it doesn't work. I'm missing something?
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.107 seconds
Donation Image