Welcome, Guest
Username: Password: Remember me

TOPIC: admin/admin.php was not found on this server

admin/admin.php was not found on this server 2 years 4 months ago #83162

  • Blaise
  • Blaise's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
Hello

I installed LimeSurvey locally, using Mamp (on a Mac, of course)

I suppose it went right since I could access limesurvey/admin/admin.php and get the "You have to login first"
I did try, using "admin" as Username and "password" as ... password.

Then I get the following message:
"The requested URL /limesurvey/admin/admin.php was not found on this server."

I am a bit puzzled :huh: , since in my understanding admin.php is generating the login form...

How can I solve that ?
Thanks
The administrator has disabled public write access.

Re: admin/admin.php was not found on this server 2 years 4 months ago #83165

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2961
  • Thank you received: 381
  • Karma: 124
That sounds like you did something wrong in the config.php with the rooturl.

Could you post the folder where you have LS installed locally and what the config.php says?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: Blaise

Re: admin/admin.php was not found on this server 2 years 4 months ago #83168

  • Blaise
  • Blaise's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
holch wrote:
That sounds like you did something wrong in the config.php with the rooturl.
Me? Something wrong? Last time was years ago!
holch wrote:
Could you post the folder where you have LS installed locally and what the config.php says?
About rooturl, the config.php, line 44, said
$rooturl = "http://{$_SERVER}/limesurvey"

Following your remarks, I changed it to incorporate path info
$rooturl = "http://{$_SERVER}/NNQ/Quest/limesurvey"
and... it worked!

Thanks a lot, holch!
The administrator has disabled public write access.

Re: admin/admin.php was not found on this server 2 years 4 months ago #83171

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2961
  • Thank you received: 381
  • Karma: 124
You are welcome!
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.101 seconds
Donation Image