Welcome, Guest
Username: Password: Remember me

TOPIC: Problems after token activation

Problems after token activation 2 years 3 months ago #82242

  • jozi
  • jozi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hi,

today I activated tokens for a survey that already worked well without tokens (I'm using LimeSurvey Version 1.92+ Build 120425). Unfortunately, it seems that something went wrong, as I'm getting the following error message when starting the token management:

"Fatal error: Call to a member function FetchRow() on a non-object in /limesurvey/admin/tokens.php on line 685"

Does anybody have an idea about this kind of problem? I would also be very thankful for help in deactivating the tokens (or the survey), because the survey cannot be used anymore. When I try to deactivate the survey in the usual way, I get the following error:

"Couldn't deactivate tokens table because:
Error on rename of './lime_tokens_11218.MYI' to './lime_old_tokens_11218_20120618180326.MYI' (Errcode: 2)

Survey was not deactivated either."

Maybe this problem is related to the fact that I also had problems with using the Template editor ("Please change the directory permissions of the folder /limesurvey/tmp in order to preview templates"). I couldn't understand this error as I set directory permissions to "rwxrwxrwx".

Help is very welcome!
The administrator has disabled public write access.

Re: Problems after token activation 2 years 3 months ago #82253

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
The problem shouldn't be related to the template issue. That is caused because the folder /tmp and /upload and all subfolders need to be writable and proper rights need to be set so the webserver can create files there.

You should be able to get the survey running if you simply delete the token table.

You can test if this is fixed at the latest version by testing our online demo which always runs the latest Limesurvey version.
Username: admin
Password: test
If you can reproduce the problem there please report back.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Problems after token activation 2 years 3 months ago #82287

  • jozi
  • jozi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Thank you for your quick reply. In the meantime I solved the problem by copying the survey, deleting the old one, and activating the tokens in the new one again. This time I had no problems. It seems difficult to explain what happenend in the first run, but fortunately it doesn't matter as everything is working now. I will make a donation after my survey is finished...

Best
The administrator has disabled public write access.

Re: Problems after token activation 2 years 3 months ago #82319

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Thanks for your feedback. If you can anyway reproduce the problem, please open a ticket at our bugtracker.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.128 seconds
Donation Image