Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: LS on XAMPP on Win 7 x32 -- ? no startup "script"??

LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82149

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
installed LS earlier today,using the latest version of LS on XAMPP x32 exe file

everything seemed to be going well, then I had to leave the program

now trying to start it up again (forgive me being a mug here)
XAMPP starts (at least the control panel opens) but with no services running -- naturally LS is also not running

what do I do now
sorry, but I've got absolutely no knowledge of Apache, MySQL or anything else more technical -- not sure if this covers the "have you followed the install directions" directive posted 6 years ago, as I don't think this form of the installer dates from that time
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82152

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Further to my query:

during initial install two "error" messages appear, both I think having to do with "localhost" -- but go by two fast for this newbie to catch,
was wondering about the config.php file, so in that file

SHOULD

$databaselocation = 'localhost'

BECOME

$databaselocation = 'russell-hp' ==> network name of machine - as known to my internet network

WHAT SHOULD

$rooturl = "http://{$_SERVER}";

BECOME?

AND

$rootdir = dirname(__FILE__)

THE "ORIGINAL" CONFIG.PHP FILE SAYS THIS SHOULDN'T HAVE TO CHANGE, BUT?

HOW ABOUT --

$rootdir = c:\xampp(__FILE__)

(and what's the file I should be looking for?)


or am I totally off the point?
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82153

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
but despite the initial "errors" appearing, LS still seems to run OK, until I want to start it up again, at which time, neither MySQL nor Apache start by themselves,
and nor, naturally, does LS -- if MySQL doesn't start, I shouldn't expect LS to start, I guess, but even when I start it, I don't know how to then start LS, since I don't know how to use MySQL
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82157

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2852
  • Thank you received: 359
  • Karma: 124
The documentations explains pretty well what you need to set. Leave localhost as localhost and leave the first part of the root url as it is. If LS ran fine after the install, then you do not need to change anything in the config file.

If your limesurvey installation is directly in the htdocs folder, then you don't need to add anything to the root url. However, if you have limesurvey installed in htdocs/limesurvey/ for example, then the code needs to look like:
$rooturl = "http://{$_SERVER['HTTP_HOST']}/limesurvey";

The issues on Xampp should be better asked at the Xampp website.

But in general there are two options:
1. you install both mysql and apache as a service, this means the webserver starts always when you start your computer and runs in the background. This might need some system rescources, but I have them running all the time without any problems.

2. whenever you want to use limesurvey on your computer you can use the Xampp control panel to start mysql and apache.

Once apache and mysql is running you can open a browser and access your limesurvey installation.

If Limesurvey is installed in htdocs/limesurvey/, then you access it via "http://localhost/limesurvey/". To access the admin screen: "http://localhost/limesurvey/admin/"
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82158

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
I do NOT find this helpful

I installed LS using the download on XAMPP option on the LS download page -- perhaps someoen familiar with the obvious problems inherent in using this option could respond
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82160

  • c_schmitz
  • c_schmitz's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 810
  • Thank you received: 115
  • Karma: 93
RustyRiley, what error messages did appear during install?
TO start the service just use the XAMPP control panel and start Apache and MySQL.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82161

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
as I said, being newbie to "server-side scripting" (??) PHP/MySQL I can't take in the entirety of the messages before they disappear and the program starts -- it ONLY starts after initial install -- LS does NOT start if I simply start XAMPP control panel and start Apache and MySQL services -- which made me think if there was some sort of script which needed to run, and which settings needed to be corrected.

As an attempt to debug the problem, I could have another go, trying to catch more of the message, but that would require un-installing XAMPP and re-installing / re-running:
"limesurvey192plus-build120613-on-xampp-win32-setup.exe"

but I was hoping to avoid that, but ....

I may have to keep up this un-install / re-install process until I can remember all of it;

(makes me wonder if I can screen capture a video of the process quickly enough?)

but thanks for your question, it encourages me someone is "listening"

Rusty
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82162

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
sending this and another message this

-- video swf file of install showing "errors" in installation process

-- video swf of lack of progress after startup of xampp/MySQL

both in zip format
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82163

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
video of lack of progress after startup of XAMPP / MySQL -- in zip format
The administrator has disabled public write access.

Re: LS on XAMPP on Win 7 x32 -- ? no startup "script"?? 2 years 4 months ago #82166

  • RustyRiley
  • RustyRiley's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
I'm a newbie on this -- can't see my files attached exemplifying the issues -- is there a size limit on attachments?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.176 seconds
Donation Image