Welcome, Guest
Username: Password: Remember me

TOPIC: Multiple numerical input problem after upgrade

Re: Multiple numerical input problem after upgrade 2 years 2 months ago #81461

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
Thanks for all your efforts on serving our users' wishes, Tom.

Just to be sure I get this right: There is a new setting at the advanced question settings which defaults to the new behavior, so all newly created questions use the new behavior.
If I update from an older version though, this setting doesn't use the default behavior but is changed for the according updated questions so they use the original, old behavior. Is that correct?

Can you add a note at the manual and post the link here, Tom?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Multiple numerical input problem after upgrade 2 years 2 months ago #81493

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
Mazi wrote:
Just to be sure I get this right: There is a new setting at the advanced question settings which defaults to the new behavior, so all newly created questions use the new behavior.
If I update from an older version though, this setting doesn't use the default behavior but is changed for the according updated questions so they use the original, old behavior. Is that correct?

Correct. Existing surveys will not have this attribute at all. When the attribute is missing, the old behavior is used (preventing users from skipping questions that have min_num_value or equals_num_value). If the author edits the question, that attribute is created, and defaults to the new behavior. So, authors editing such questions should pay attention to whether they want the old or new behavior.

I have updated the documentation.
The administrator has disabled public write access.

Re: Multiple numerical input problem after upgrade 2 years 2 months ago #81527

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
Thanks for updating the docs!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Multiple numerical input problem after upgrade 1 year 9 months ago #88277

  • jelo
  • jelo's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 467
  • Thank you received: 52
  • Karma: 16
Can somebody confirm that value range allows missing is not working with mandatory questions.

On 1.92 and 2.0 the mandatory option is displaying the empty cells red even when Value range allows missing is set to yes.

docs.limesurvey.org/Advanced+question+se...range_allows_missing
The administrator has disabled public write access.

Re: Multiple numerical input problem after upgrade 1 year 9 months ago #88287

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6276
  • Thank you received: 801
  • Karma: 240
jelo wrote:
Can somebody confirm that value range allows missing is not working with mandatory questions.

On 1.92 and 2.0 the mandatory option is displaying the empty cells red even when Value range allows missing is set to yes.

docs.limesurvey.org/Advanced+question+se...range_allows_missing
A mandatory question is mandatory, then you have to answer each subquestion.

mandatory => all question have to be answered
missing => question can not be answered.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.127 seconds
Donation Image