Welcome, Guest
Username: Password: Remember me

TOPIC: Fancy Url Feature not working

Fancy Url Feature not working 2 years 6 months ago #80147

  • JackChow
  • JackChow's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Karma: 0
I followed the instructions
1) renamed htaccess.txt to .htaccess under LS root folder
2) updated $modrewrite = 1; in config-defaults.php

But the fancy urls are not generated. Am I missing anything ?

Limesurvey Version : 1.92+ build 120509

The surveys are activated when testing this feature.
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80199

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
How does the survey feature look like that is shown after having selected a survey from the drop down tip right at the admin back-end?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80218

  • JackChow
  • JackChow's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Karma: 0
I assume you are referring under administration. Once I select the active survey from right drop down it looks same like before

The url is like this /admin.php?sid=48319

I checked the mod_rewrite on my apache is on. I checked the database the fancy urls are not created. What could be the issue ? Is this feature working for you ?
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80232

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
Please post the content of the .htaccess file.

Are there any other .htaccess files at any above folders?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80237

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 826
  • Thank you received: 117
  • Karma: 93
Fancy URL has nothing to do with the administration URLs. It is only meant for the survey URLs - the only change you would notice in the administration interface is that the Survey URL in the quick overview below the survey toolbar has changed.
Also if you send any invitations the fancy version URL in the invitation email will be used.

That's it.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80241

  • Fred
  • Fred's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 163
  • Thank you received: 5
  • Karma: 3
Not sure if this helps, but you mentioned changing the setting in config-defaults.php. Did you try copying the mod-rewrite setting to config.php instead?

The LimeSurvey doc recommends doing it that way:
If you want to change these settings please do not change it in config-defaults.php but copy the particular setting/line over to config.php and change it there. All settings in config.php overwrite the default values from config-defaults.php and starting with version 1.87 some of these settings get overridden in the Global settings dialog.

docs.limesurvey.org/Optional+settings&st...tions+for+LimeSurvey
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80244

  • JackChow
  • JackChow's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Karma: 0
This is the content of htaccess file


## MOD_REWRITE for LimeSurvey ##
<IfModule mod_rewrite.c>
RewriteEngine On

## DONT TOUCH ANYTHING ##
# Only with survey code
# server.fr/123456
RewriteRule ^([0-9]+)/*$ index.php?sid=$1 [L,QSA]

# Survey code + Lang : server.fr/123456/lang-fr
RewriteRule ^([0-9]+)/lang-([^/]*)/*$ index.php?sid=$1&lang=$2 [L,QSA]

# Survey code + Lang + Token : server.fr/123456/lang-fr/tk-sdlfkjozeiru
RewriteRule ^([0-9]+)/lang-([^/]*)/tk-([^/]*)/*$ index.php?sid=$1&lang=$2&token=$3 [L,QSA]

# Survey code + Token : server.fr/123456/tk-sdlfkjozeiru
RewriteRule ^([0-9]+)/tk-([^/]*)/*$ index.php?sid=$1&token=$2 [L,QSA]
</IfModule>


Yes there is one more htaccess file in www root folder. The contents of it are

RewriteEngine On
RewriteRule ^$ /survey [L]

ErrorDocument 403 /survey/Index.php
ErrorDocument 404 /survey/Index.php

Tried putting in config.php, deleted cookies, restarted the webserver still same issue.
The administrator has disabled public write access.

Re: Fancy Url Feature not working 2 years 6 months ago #80486

  • JackChow
  • JackChow's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Karma: 0
Were you able to reproduce the error ?
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.128 seconds
Donation Image